Ask Your Question
1

Another ssh question

asked 2012-03-19 15:11:27 -0600

remands gravatar image

In Fedora 16 after I append idrsa.pub to .ssh/authorizekey, i still get asked for a password.I am working on clustering and MPI. On Linux Mint 12 after I do the apppend and all password requests stop. How do i get ssh to autorize login with a rsa key and not ask for a password?

Ben

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2012-03-21 07:38:56 -0600

Peter Scott gravatar image

updated 2012-03-21 07:43:23 -0600

ssh is usually set up to ask for passwords only after trying public keys so there must be something wrong with your setting up of the authorized_keys file entry. Do you have ssh-agent or gnome keyring running? Do you have a pass-phrase for the id_rsa.pub? Were you asked for it?

edit flag offensive delete link more
0

answered 2012-03-19 16:29:15 -0600

updated 2012-03-19 16:30:44 -0600

You have to disable passwords in /etc/ssh/sshd_config and restart the ssh server

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no

systemctl reload sshd.service
edit flag offensive delete link more
0

answered 2012-03-21 15:00:26 -0600

kubo gravatar image

Check permissions of ~/.ssh directory and ~/.ssh/authorized_keys file. Nobody except current user shouldn't write there and openssh server check it (you can find some info in log).

chown `whoami` ~/.ssh -R
chmod 0700 ~/.ssh
chmod 0600 ~/.authorized_keys
edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-03-19 15:11:27 -0600

Seen: 805 times

Last updated: Mar 21 '12