Ask Your Question
0

Dual boot Fedora 16 / Windows

asked 2011-11-29 16:36:54 -0500

jdeltoro1973 gravatar image

updated 2011-12-03 17:46:40 -0500

mether gravatar image

I installed Fedora 16 in a Laptop at work, I use it most of the time but every now and then someone else uses it for presentations and the GRUB menu appears and people panic; I've tried several ways to set windows as the default OS at boot but when the kernel updates once again I have this problem, so my question is: Is there an easy way to set Windows as the default OS at boot?

edit retag flag offensive close merge delete

Comments

3

You need to know your windows menu entry

cat /boot/grub2/grub.cfg |grep Windows

will show something like

menuentry "Windows XP (loader) (on /dev/sda1)" --class windows --class os {

Set it as default

grub2-set-default "Windows XP (loader) (on /dev/sda1)"

Update grub

grub2-mkconfig -o /boot/grub2/grub.cfg

See also

http://fedoraproject.org/wiki/Grub2#Setting_default_entry

bodhi.zazen gravatar imagebodhi.zazen ( 2011-11-29 16:52:04 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
0

answered 2013-07-17 23:28:24 -0500

tcoburn4 gravatar image

no need to use sudo at beginning of each command if you do.

su root (then type in root password)

from a command prompt. that is what I do, especially if I'm going to use other commands like yum update also. forget about sudo

edit flag offensive delete link more
0

answered 2013-02-28 23:04:32 -0500

I have windows 7 Home Premium and Fedora 18. Your advice works, however I would recommend to write a full path. In my case every time I wrote a command, I needed to add sudo at the beginning.

For newbies, like me is very important.

edit flag offensive delete link more
0

answered 2013-07-03 16:16:10 -0500

tcoburn4 gravatar image

grub2-set-default "Windows 7 (loader) (on /dev/sda1)" grub2-mkconfig -o /boot/grub2/grub.cfg

has worked just fine for me in Fedora 16,17,18, and 19 :)

in Windows 8, I just change the 7 to an 8, works just fine :)

edit flag offensive delete link more
0

answered 2013-01-29 14:30:07 -0500

tcoburn gravatar image

Am facing the same issue in Fedora 18. I had thought about changing the menuentry so it reads "Windows 7 Home Premium" so at least general people would see that and think "oh yeah I should select that!" otherwise people are like " (loader) (on /dev/sda1) WHAT?" since ya know even most IT guys in this world we live in don't know what /dev/sda1 means. they know C: drive D: drive etc but not /dev/sda1 er whatever lol

the other thought that occured to me, is there a way to remove entries? because to tell you the truth, I NEVER boot into previous kernels when a new one comes out. AND my laptops D: drive has this recovery partition that grub wants to show up every time. is there a way to remove those partitions but yet still have new entries made for new kernel entries?

edit flag offensive delete link more

Comments

grub2-set-default "Windows 7 (loader) (on /dev/sda1)"

tcoburn4 gravatar imagetcoburn4 ( 2013-07-03 16:16:57 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2011-11-29 16:36:54 -0500

Seen: 22,127 times

Last updated: Jul 17 '13