Ask Your Question
0

How can i get tab autocomplete in maxima or wxmaxima?

asked 2016-08-10 05:57:54 -0500

smurfendrek123 gravatar image

I've heard of there being autocomplete on ubuntu, but on fedora there's no autocomplete when i launch maxima.

I read somewhere that this might be fixed by launching maxima with a different runtime, and i can install different maxima runtimes, but i don't know how to launch maxima with those runtimes.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-08-10 06:08:57 -0500

smurfendrek123 gravatar image

updated 2016-08-10 06:26:39 -0500

You have to launch maxima with the command rmaxima instead of just maxima.

This doesn't work very well though, a lot of commands don't seem to autocomplete.

If anyone has any insights on a file i could edit somewhere to add this, or a way to fix this, that would be great.

edit flag offensive delete link more

Comments

1

You may want to get in touch with the developers.... http://maxima.sourceforge.net/maximal...

florian gravatar imageflorian ( 2016-08-10 09:24:11 -0500 )edit
0

answered 2016-08-10 20:58:51 -0500

Houdini gravatar image

It is there. Use Ctrl+Tab instead of Tab alone.

edit flag offensive delete link more

Comments

Or Ctrl+K. It's all present in menu: Edit.

Houdini gravatar imageHoudini ( 2016-08-10 21:00:37 -0500 )edit

Are you on fedora, because i've heard that it has something to do with the runtimes or something, and that the runtime changes whether or not there's autocomplete support.

And i'm talking about cli maxima, ctrl+k is for wxmaxima.

smurfendrek123 gravatar imagesmurfendrek123 ( 2016-08-11 03:09:41 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-08-10 05:57:54 -0500

Seen: 377 times

Last updated: Aug 10 '16