Ask Your Question
2

Fedora 17 Desktop issues

asked 2013-01-12 09:00:58 -0500

Tersal gravatar image

updated 2013-01-12 10:43:45 -0500

Jomoos gravatar image

I cannot drag to my desktop. I can create files in the desktop directory however they do not show on the desktop. Nor can I drag items to the desktop.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
3

answered 2013-01-12 10:41:24 -0500

Jomoos gravatar image

GNOME 3 is designed to be uncluttered, simple and to bring an air of minimalism while still providing the features you need at your fingertips. As a result, by default, the desktop is just your wallpaper. There are no desktop icons because you shouldn’t have to move a window around to see what’s behind it on your desktop, as well as how cluttered and ugly desktops can become over time.

Now, to enable features like icons, files, dragging etc., you need to tell the file manager to handle the desktop.

The easiest way to do that is to install gnome-tweak-tool. You can install it by running the following command in terminal.

sudo yum install -y gnome-tweak-tool

It will call itself "Advanced Settings" in the applications list. Run it, and go to the "Desktop" tab, and enable the "Have file manager handle the desktop" check-box. Similarly you can make or not make computer icon, home icon, network servers icon and trash icon visible on the desktop and also opt whether to show mounted volumes on the desktop.

gnome tweak tool

Then you can drag files to desktop or create "short-cuts" (symbolic links, or symlinks for short, in Linux terminology) by middle-dragging a document onto the desktop and clicking "Link here" in the pop-up menu.

edit flag offensive delete link more
2

answered 2013-01-12 09:51:36 -0500

Emin Tufan gravatar image

updated 2013-01-12 09:53:46 -0500

How to enable desktop in Fedora

image description

su -c 'yum -y install dconf-editor'

After installing dconf-editor, click alt+f2 and type:

dconf-editor

On the left handside panel expand: org->gnome->desktop and click on "Background"

On the right hand side enable the "Show-Desktop-Icons"

Source: https://ask.fedoraproject.org/question/2621/fedora-gnome-3-desktop-questions

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-01-12 09:00:58 -0500

Seen: 3,402 times

Last updated: Jan 12 '13