Ask Your Question
0

Skipping Fedora Updates in dnf Command

asked 2016-07-31 00:13:00 -0500

RalphKirito gravatar image

I'm using Fedora 24 and every time that I'll install some package, Fedora updates.

I usesudo dnf install vlc to install vlc. However, instead of downloading and installing it automatically, updates were first downloaded like Fedora_x86_x64 - Updates and it sucks because I'm on a metered data. I've been searching anywhere else to find solution for this but no luck.

Is there a way to skip this or to disable this permanently? I'm anticipating for something like disabling this and installing those updates manually instead.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-07-31 13:37:54 -0500

aeperezt gravatar image

You can run sudo dnf update first and the install this will avoid the update for the next install command, if you want to disable update completly then you can disable Fedora Update repo you can do that at run time like this:

sudo dnf install vlc --disablerepo=updates

Or edit the Fedora repo configure file and set enabled=1 to enabled=0 but this will disable it permanently so be careful, to do so you need to edit the file located at /etc/yum.repos.d/fedora-updates.repo

You also need to consider that the vlc package may require packages version that are only in the update repo.

Hope this help you. Good Luck

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-07-31 00:13:00 -0500

Seen: 777 times

Last updated: Jul 31 '16