Ask Your Question

My mouse scrolls inverted after reboot [closed]

asked 2016-07-30 14:06:12 -0500

kevoh1516 gravatar image

updated 2016-07-30 17:35:16 -0500

After a reboot my mouse has started to scroll inverted.

When I scroll up, the page moves down and vice versa. I tried to enter: sudo dnf install xorg-x11-drv-libinput according to this post but apparently it is already installed on my system.

How can I make my mouse scroll normally?

Here is what I get when I type xinput list (I am on a desktop using a mouse):

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ImPS/2 BYD TouchPad                       id=9    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=8    [slave  keyboard (3)]

I have also tried to switch mouses with no luck so it is not a hardware issue.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by hhlp
close date 2016-08-04 04:30:31.300031


While not sure, you have to change the "Natural displacement" on your mouse options in the control panel

aeperezt gravatar imageaeperezt ( 2016-07-30 15:09:48 -0500 )edit

@aeperezt Tried it both on and off. Still inverted with both options.

kevoh1516 gravatar imagekevoh1516 ( 2016-07-30 15:15:17 -0500 )edit

Look at this it may help you but i'm wondering something are you running wayland?

aeperezt gravatar imageaeperezt ( 2016-07-30 15:43:46 -0500 )edit

@aeperezt I am not running wayland. Should I be? I also read the link you gave me. Made me think that my problem has to do something with xinput? The link seems to have a problem similar to mine but with clicks. Not really sure how to apply it to my situation. If there's no simple solution and I have to do a whole bunch of back-end command line stuff, I would rather just get used to inverted scrolling. Hopefully there is a simple solution?

kevoh1516 gravatar imagekevoh1516 ( 2016-07-30 17:30:12 -0500 )edit

I faced similar issue after upgrading to Fedora 24. Have you tried rebooting with old kernel to see if that fixes the issue? More people are having similar issues

zermatt gravatar imagezermatt ( 2016-07-31 09:24:15 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2016-08-03 21:04:55 -0500

whot gravatar image

That's a kernel bug with that specific device, have a look at

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-07-30 13:35:06 -0500

Seen: 860 times

Last updated: Aug 03 '16