Ask Your Question
0

How do I install Ati 6520G Drivers?

asked 2012-01-20 15:43:28 -0500

Rob gravatar image

updated 2012-01-20 15:43:46 -0500

I've got an HP G6-1207SA laptop with the following specification:

AMD A6-3400M CPU, 6GB DDR3 RAM, Radeon HD 6520G (APU), Verbatim Black Edition 128GB SSD

I'm unable to boot into Fedora 16's live disc, I've just got a blank screen.

I'm able to boot in fallback mode and install the OS. But how do I install the drivers for my graphics card?

I've tried downloading and installing directly from AMD's website, it installed, but was still in fallback mode, not Gnome Shell.

Thanks in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2012-01-30 10:48:01 -0500

BRPocock gravatar image

One possibility is to use RPMFusion.

This is an add-on repository of software that works with the normal Fedora repositories, but isn't shipped by Fedora for various reasons.

You can install RPMFusion support by visiting http://rpmfusion.org/ and clicking the links for the “free” and “non-free” repositories to install them. (Just click the links, and choose to open them with the default program, PackageKit. You'll be prompted for your password a couple of times.)

Once you've enabled the repository, you can enter the package manager (Activities → Applications → System Tools → Add/Remove Applications) and search for xorg-x11-drv-catalyst. Check the box beside this package, and click Apply. This should pull in (among other things) kmod-catalyst as “required additional packages”. Confirm, possibly key in your password again, and then (one more thing!)…

Once the packages are installed, open Terminal (Activities → Applications → System Tools → Terminal) and type

    sudo aticonfig --initial

In order for the new drivers to take effect, you can just reboot your system as usual, and they should take effect.

As with using the proprietary nVidia drivers, if you plan to reboot or shut down your system, it's wise to always make sure that you have updated your software completely. If your ATI drivers and kernel are not updated to the same level, you may not get a login screen after rebooting. If this should happen, the “Grub” bootloader menu can be used to “go back” to an earlier kernel version. (Pick a lower-numbered kernel from the boot-time menu right after your computer manufacturer's logo screen.) You can also boot into “rescue mode” (single-user text mode) and run pkcon update kmod-catalyst kernel to update those two packages, in a pinch. This is the “danger” of using the ATI-provided drivers instead of the Fedora default ones.

This page: http://gofedora.com/how-to-install-ati-catalyst-fglrx-98-drivers-fedora-11/ may have some additional suggestions, but hopefully you shouldn't need to do anything else. You might need to add the blacklist entries it mentions to a file in /etc/modprobe.d but I hope that RPMFusion will have done that already for you. Unfortunately, I don't have such a video chipset to test.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-01-20 15:43:28 -0500

Seen: 1,693 times

Last updated: Jan 30 '12