Ask Your Question
1

fedora 17 network not starting, works fine starting manually

asked 2012-12-15 16:06:09 -0500

sudoyang gravatar image

updated 2012-12-15 16:08:07 -0500

I'm using Fedora 17. For some reason the network does not start automatically when booting the machine but works fine when starting manually.

My system is set to start automatically on runlevel 5:

# ls -l /etc/systemd/system/default.target
lrwxrwxrwx. 1 root root 36 Apr 15  2012 /etc/systemd/system/default.target -> /lib/systemd/system/runlevel5.target

Bridge startup script:

# cat /etc/sysconfig/network-scripts/ifcfg-br0
DEVICE=br0
ONBOOT=yes
BOOTPROTO=static
TYPE=Bridge
DELAY=0
IPADDR=192.168.1.100
NETMASK=255.255.255.0
GATEWAY=192.168.1.254
DNS1=208.67.222.222
DNS2=208.67.220.220

and the main config file for the physical NIC:

# cat /etc/sysconfig/network-scripts/ifcfg-p20p1
DEVICE="p20p1"
ONBOOT=yes
HWADDR=00:1A:4D:46:CB:AA
BRIDGE=br0
NM_CONTROLLED=yes

I believe I tried this on CentOS 6.x and it works fine there. I'm not too familiar with systemd, yet, to troubleshoot this properly.

Any help is appreciated. Thanks

edit retag flag offensive close merge delete

Comments

I think you want NM_CONTROLLED=no here.

randomuser gravatar imagerandomuser ( 2012-12-16 00:40:14 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-12-20 22:43:24 -0500

btl3ss gravatar image

try chkconfig network on reboot

I have 2 physical nics am using NetworkManager to control the primary which comes up fine but NM doesn't do Bridge interfaces yet so I also turned on the older chkconfig network which is off by default (not sure when this changed) and now my NM and Br interface all start on boot. Not sure if you should have both NM and network on at the same time but it works.

ifcfg-br0

DEVICE=br0 TYPE=Bridge ONBOOT=yes DELAY=0

ifcfg-p4p2

TYPE=Ethernet BOOTPROTO=none IPADDR0=10.0.0.1 PREFIX0=24 DEFROUTE=yes IPV4FAILUREFATAL=no IPV6INIT=no NAME=p4p2 ONBOOT=yes HWADDR= BRIDGE=br0

I am a longtime RHEL/CentOS user moving to fedora and many thing are diff. good luck.

edit flag offensive delete link more

Comments

bitl3ss, you'll probably find http://fedoraproject.org/wiki/SysVini... to be useful.

randomuser gravatar imagerandomuser ( 2012-12-22 03:03:52 -0500 )edit
1

answered 2012-12-16 00:04:07 -0500

Saeed Zarinfam gravatar image
  1. From "gnome shell status bar" click on network icon.
  2. From popup select "Network Setting".
  3. In the Network dialogue click on Option button.
  4. In Editing dialogue check "Connect automatically" check box (located at top of the form).

Have a nice time.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-12-15 16:06:09 -0500

Seen: 5,421 times

Last updated: Dec 20 '12