Ask Your Question
1

Cannot start X server on F24

asked 2016-07-12 14:28:56 -0500

mseleng gravatar image

Hi, after my today's dnf update I can no longer start sddm nor the X.

I am not sure, whether it was caused by the update itself, because I cannot see any package, that could potentially brick it. (see this paste for info about updated packages). Moreover I also installed qt5-qtgraphicaleffects, but I don't think it could have caused the problem (it is already removed, but nothing has changed).

I am typing here, just because I was able to somehow start gdm and log into Gnome on Wayland (that's the only one that works); normally I use the Xfce.

Here is the most relevant /var/log/Xorg.0.log:

[   974.606] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[   974.607] (II) xfree86: Adding drm device (/dev/dri/card0)
[   974.608] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[   974.610] (--) PCI:*(0:0:2:0) 8086:0166:17aa:3901 rev 9, Mem @ 0xd3400000/4194304, 0xe0000000/268435456, I/O @ 0x00004000/64, BIOS @ 0x????????/131072
[   974.610] (II) LoadModule: "glx"
[   974.610] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   974.613] (II) Module glx: vendor="X.Org Foundation"
[   974.613]    compiled for 1.18.3, module version = 1.0.0
[   974.613]    ABI class: X.Org Server Extension, version 9.0
[   974.613] (==) AIGLX enabled
[   974.613] (II) LoadModule: "nvidia"
[   974.614] (WW) Warning, couldn't open module nvidia
[   974.614] (II) UnloadModule: "nvidia"
[   974.614] (II) Unloading nvidia
[   974.614] (EE) Failed to load module "nvidia" (module does not exist, 0)
[   974.614] (EE) No drivers available.
[   974.614] (EE) 
Fatal server error:
[   974.614] (EE) no screens found(EE) 
[   974.614] (EE) 
Please consult the Fedora Project support 
     at http://wiki.x.org
 for help. 
[   974.614] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   974.614] (EE)

Here I need to say that until today everything worked perfectly (I do have nvidia drivers through bumblebee and they did not do any problems till now)

When I run sudo nvidia-xconfig it finishes successfully and here's the xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 367.27  (buildmeister@swio-display-x64-rhel04-12)  Thu Jun  9 19:24:36 PDT 2016


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I have absolutely no clue about what is going on ... (more)

edit retag flag offensive close merge delete

Comments

Why are you using sddm, instead of Xfce's default of lightdm? Also, once you had gdm running, did you try starting Xfce? Please edit your question to add the response to systemctl status sddm as that may tell us why it's failing. (Note that sudo isn't needed.)

sideburns gravatar imagesideburns ( 2016-07-12 16:19:37 -0500 )edit

I would also recommend to try a 'sudo modprobe nvidia' on a shell. The Nvidia drivers should be built by bumblebee under /lib/modules/uname -r/kernel/drivers/extra (not sure of the exact path)

Fabash gravatar imageFabash ( 2016-07-13 00:12:05 -0500 )edit

@sideburnssddm was only preference thing, nothing important, it just looks better for me than the lightDM (had that also). Yes, when in gdm I cannot log into any other DM (Gnome/Xfce). I ran systemctl sddm status on when this occurred for the very first time and (I did not saved the output) there was something 'bout core dump. I don't think this is related to sddm anymore, because of unability to configure X through X -configure. Today I ran dnf update which updated Xorg, but nothing has changed yet.

mseleng gravatar imagemseleng ( 2016-07-13 04:05:05 -0500 )edit

@fabashsudo modprobe nvidia output the following:

modprobe: ERROR: could not insert 'nvidia': No such device

Probably really issue with the driver. Maybe I need to wait for some update and use gnome on wayland till then :(. I was thinking that maybe the selinux-policy update broke something, because I read earlier, when isntalling drivers that sometimes selinux prevents nvidia modules from loading.

mseleng gravatar imagemseleng ( 2016-07-13 04:09:06 -0500 )edit

Maybe you could post the extract of dmesg result, when you execute modprobe, to see why you can't load the module. If it comes indeed with selinux issue, you can disable it by updating the Kernel command line and add 'selinux=0', either at boot time in grub command line, either by default by editing /etc/default/grub and regenerate the grub.cfg

I'm able to load last NvIdia v367.27 using kernel 4.5.7, and I have disabled selinux also.

Fabash gravatar imageFabash ( 2016-07-13 07:18:09 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-07-12 19:55:05 -0500

ssieb gravatar image

updated 2016-07-13 13:17:48 -0500

The GDM login screen by default runs on Wayland, which corresponds to the Gnome on Wayland desktop working.

I assume you have at some point installed the closed NVidia drivers either as kmod or akmod and some update has either included a new kernel or somehow otherwise messed up that driver so X won't start. It can't find the nvidia module. You need to fix that or remove the X config so it will use nouveau instead.

Update: According to the NVidia page, your card should be supported, but the driver is pretty clear that it doesn't agree:

NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0de3)
NVRM: installed in this system is not supported by the 367.27
NVRM: NVIDIA Linux driver release.

I'm assuming it used to work, so you'll have to take that up with NVidia. In the meantime, try out nouveau.

edit flag offensive delete link more

Comments

If akmod-nvidia is active, it will create a new kmod at boot if there isn't one for the current kernel. And, if I'm not mistaken, support for kmod-nvidia has been dropped, leaving only akmod.

sideburns gravatar imagesideburns ( 2016-07-12 20:26:34 -0500 )edit
1

I see from further comments that the kernel driver is missing, but from the initial question, the Xorg driver is also missing.

ssieb gravatar imagessieb ( 2016-07-13 13:06:24 -0500 )edit

Also, you're using bumblebee? Does that mean you have a Optimus system? If you do use nouveau, I think you will need to switch to Prime instead of bumblebee.

See https://wiki.archlinux.org/index.php/... and https://wiki.archlinux.org/index.php/...

ssieb gravatar imagessieb ( 2016-07-13 13:23:39 -0500 )edit

Can you, please suggest how to do so? (replace with nouveau), I mean getting rid of nvidia stuff? And yes, I am using bumblebee, mostly because of steam games. Moreover, it is just one day without Xfce and I am starting to feel terrible about gnome-shell memory consumption (2.1GB vs. ~750MB with Xfce)..working with IDEA or Android Studio is pretty pain as it (the Studio) consumes about 5GB. Anyway, why do I need to switch to PRIME?

mseleng gravatar imagemseleng ( 2016-07-13 15:21:12 -0500 )edit

Prime is now the fully supported method taking over from bumblebee. Support for it is in the kernel and Xorg. See https://wiki.freedesktop.org/nouveau/... for more details. Bumblebee is still needed for the closed NVidia driver.

To get back to nouveau, you will need to remove any nvidia driver packages you have installed and make sure that nouveau isn't blacklisted. Run lsmod and see if the nouveau driver is loaded. You will also need to remove the Xorg.conf that you created and possibly replace it with something else based on that web page.

ssieb gravatar imagessieb ( 2016-07-13 16:36:21 -0500 )edit
0

answered 2016-07-21 18:32:59 -0500

mseleng gravatar image

The answer is even easier as I have finally found out on Ubuntu forums: I just needed to run optirun nvidia-settings -c :8 instead of just nvidia-settings to configure X. I think that's all and I can mark this as solved.

edit flag offensive delete link more

Comments

Please, mark your own answer as the right answer, so others could be helped easier!

Mateus Felipe gravatar imageMateus Felipe ( 2017-01-05 10:10:51 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-07-12 14:28:56 -0500

Seen: 6,278 times

Last updated: Jul 21 '16