Ask Your Question
0

Laptop enters sleep/suspend mode when lid closes despite effort to stop

asked 2016-07-09 19:58:31 -0500

PhyChm gravatar image

updated 2016-07-10 09:36:12 -0500

I have tried the power settings under the default gnome app, dconf-editor, and tried to edit logind.conf however nothing has worked. Everytime I close the lid, the laptop sleeps. I have been trying to convert old hardware to a cloud server. Which was successful except for this slight problem, if I close the lid the laptop sleeps and the server goes down, but comes back up when I open it.

Fedora 24 WS.

Update:

I even tried disabling sleep/suspend and Hybernate entirely using

sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

but that didn't work. So after unmasking that, I tried a different desktop environment (XFCE) which does exactly what I need it to do, I dunno if its something in Gnome or what -- but XFCE works.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-07-10 13:52:58 -0500

DMH gravatar image

On Fedora 24 WS, using the Gnome Tweak Tool works for me.

If you don't have it installed, then:

sudo dnf install gnome-tweak-tool

Once you have it installed, you can run it and select the "Power" section from the menu on the left of the screen. You'll see an item "When Laptop Lid is Closed" with "Don't suspend on lid close" written underneath. To the write of this text there is a switch to enable or disable this setting.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-07-09 19:58:31 -0500

Seen: 336 times

Last updated: Jul 10 '16