Ask Your Question
0

VLC on FC24

asked 2016-07-09 10:04:27 -0500

madchem gravatar image

Hi folks!

Its problem with mp4, mov, flv and so on video formats. I've installed VLC from RPMfusion, gstreamer and x264, x265. But no effect. Every time VLC prints the message

VLC could not decode the format "h264" (H264 - MPEG-4 AVC (part 10))

Installed programs, libs and codecs:

[madchem@desktop ~]$ dnf list installed ffmpeg gstreamer{,1}\* x26\* vlc\* | awk '{ print $1}'
ffmpeg.x86_64
gstreamer.x86_64
gstreamer-devel-docs.noarch
gstreamer-ffmpeg.x86_64
gstreamer-plugin-crystalhd.x86_64
gstreamer-plugins-bad.x86_64
gstreamer-plugins-bad-free.x86_64
gstreamer-plugins-bad-free-extras.x86_64
gstreamer-plugins-bad-nonfree.x86_64
gstreamer-plugins-base.x86_64
gstreamer-plugins-ugly.x86_64
gstreamer-tools.x86_64
gstreamer1.i686
gstreamer1.i686
gstreamer1.x86_64
gstreamer1.x86_64
gstreamer1-devel.x86_64
gstreamer1-devel.x86_64
gstreamer1-devel-docs.noarch
gstreamer1-devel-docs.noarch
gstreamer1-libav.x86_64
gstreamer1-libav.x86_64
gstreamer1-libav-devel-docs.noarch
gstreamer1-libav-devel-docs.noarch
gstreamer1-plugins-bad-free.x86_64
gstreamer1-plugins-bad-free.x86_64
gstreamer1-plugins-bad-free-devel.x86_64
gstreamer1-plugins-bad-free-devel.x86_64
gstreamer1-plugins-bad-free-extras.x86_64
gstreamer1-plugins-bad-free-extras.x86_64
gstreamer1-plugins-bad-free-fluidsynth.x86_64
gstreamer1-plugins-bad-free-fluidsynth.x86_64
gstreamer1-plugins-bad-freeworld.x86_64
gstreamer1-plugins-bad-freeworld.x86_64
gstreamer1-plugins-base.i686
gstreamer1-plugins-base.i686
gstreamer1-plugins-base.x86_64
gstreamer1-plugins-base.x86_64
gstreamer1-plugins-base-devel.x86_64
gstreamer1-plugins-base-devel.x86_64
gstreamer1-plugins-base-devel-docs.noarch
gstreamer1-plugins-base-devel-docs.noarch
gstreamer1-plugins-base-tools.x86_64
gstreamer1-plugins-base-tools.x86_64
gstreamer1-plugins-entrans.x86_64
gstreamer1-plugins-entrans.x86_64
gstreamer1-plugins-entrans-docs.noarch
gstreamer1-plugins-entrans-docs.noarch
gstreamer1-plugins-fc.x86_64
gstreamer1-plugins-fc.x86_64
gstreamer1-plugins-good.x86_64
gstreamer1-plugins-good.x86_64
gstreamer1-plugins-good-extras.x86_64
gstreamer1-plugins-good-extras.x86_64
gstreamer1-plugins-ugly.x86_64
gstreamer1-plugins-ugly.x86_64
gstreamer1-plugins-ugly-devel-docs.noarch
gstreamer1-plugins-ugly-devel-docs.noarch
gstreamer1-rtsp-server.x86_64
gstreamer1-rtsp-server.x86_64
gstreamer1-rtsp-server-devel.x86_64
gstreamer1-rtsp-server-devel.x86_64
gstreamer1-rtsp-server-devel-docs.noarch
gstreamer1-rtsp-server-devel-docs.noarch
gstreamer1-vaapi.x86_64
gstreamer1-vaapi.x86_64
gstreamer1-vaapi-devel-docs.noarch
gstreamer1-vaapi-devel-docs.noarch
vlc.x86_64
vlc-core.x86_64
vlc-extras.x86_64
x264.x86_64
x264-devel.x86_64
x264-libs.x86_64
x265.x86_64
x265-devel.x86_64
x265-libs.x86_64

I have no idea what is wrong.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-07-09 12:08:15 -0500

mikechav gravatar image

Try sudo dnf install openh264

edit flag offensive delete link more

Comments

No effect. I can't even watch my Blender video. It's no MJPG and MKV codecs.

madchem gravatar imagemadchem ( 2016-07-09 13:53:57 -0500 )edit
0

answered 2016-07-09 15:13:47 -0500

madchem gravatar image

I've found 'bad' solution.

It seems that vlc could not find libvpx.so.2 library. So, when I run

LD_LIBRARY_PATH=/usr/lib64 vlc myvideo.mp4

it works. Is there any way to link /usr/lib64 directory for vlc?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-07-09 10:04:27 -0500

Seen: 528 times

Last updated: Jul 09 '16