Ask Your Question
0

Cannot resolve local domain name on Fedora 23

asked 2016-07-08 04:47:09 -0500

Alexander Nyrkov gravatar image

updated 2016-07-11 02:17:03 -0500

Hi,

I'm having troubles accessing local corporate network resources under Fedora 23.

Let's say my corporate domain is my.local.

I can easily ping local resources by name omitting the domain part:

$ ping mail
PING mail.my.local (10.54.20.43) 56(84) bytes of data.
64 bytes from mail.my.local (10.54.20.43): icmp_seq=1 ttl=124 time=53.7 ms
...

But when I try to address the very same server by its full name, mail.my.local ping says it cannot be resolved

$ ping mail.my.local
ping: unknown host mail.my.local

Though nslookup retrieves IP addresses correctly

$ nslookup mail.my.local
Server:     10.77.10.55
Address:    10.77.10.55#53

Name:   mail.my.local
Address: 10.54.224.209
Name:   mail.my.local
Address: 10.54.20.43

My /etc/resolv.conf file generated by network manager looks sane

# Generated by NetworkManager
search my.local
nameserver 10.77.10.55
nameserver 10.77.10.54
nameserver 10.54.18.111

I've lost the whole day trying to figure out what's going wrong and failed to find anything relevant.

Any leads on either debugging or the source of the problem itself are much appreciated.

edit retag flag offensive close merge delete

Comments

try set ndots:1 to see if that make it works or ndots:2 on resolv.conf

Hope that help

aeperezt gravatar imageaeperezt ( 2016-07-08 10:48:55 -0500 )edit

Thank you, I'll try that when I get to the office on Monday. This also led me to reading the resolv.conf man page which I should have done earlier.

Alexander Nyrkov gravatar imageAlexander Nyrkov ( 2016-07-09 08:41:16 -0500 )edit

Unfortunately playing with options ndots:x didn't help

Alexander Nyrkov gravatar imageAlexander Nyrkov ( 2016-07-11 01:57:10 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-07-11 03:47:05 -0500

jorti gravatar image

That domain is probably conflicting with Avahi local domain. Try changing the line hosts in /etc/nsswitch.conf to this:

hosts:      files dns myhostname mymachines
edit flag offensive delete link more

Comments

Thank you, that did it! Meanwhile I'll google a bit about how exactly that works :)

Alexander Nyrkov gravatar imageAlexander Nyrkov ( 2016-07-11 03:59:35 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-07-08 03:51:22 -0500

Seen: 1,741 times

Last updated: Jul 11 '16