Ask Your Question
1

Is this expected behavior for a MacBook touchpad in Fedora 24?

asked 2016-07-06 23:07:00 -0500

prwood gravatar image

I've just installed Fedora 24 on a MacBook (Core 2 Duo, id MacBook4,1) and am dual-booting with Mac OS X 10.7.5. Things are mostly good so far. The glitchiest thing, however, is the trackpad. I just want to confirm whether the following are expected behaviors for a MacBook touchpad under Fedora 24. If they are expected behaviors, is there a way to tweak them, and if they're not expected, is there a way to fix them?

First, here is how the device is listed in libinput-list-devices:

Device:           appletouch
Kernel:           /dev/input/event10
Group:            8
Seat:             seat0, default
Size:             110.45x82.14mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    none
Disable-w-typing: enabled
Accel profiles:   none
  1. The rightmost 1/4 of the trackpad cannot independently initiate events, apparently. It can be used in conjunction with a tap or gesture that starts in the left 3/4 of the trackpad. For example, a two-fingered scroll with one finger on the left side and one on the right, or a two-fingered tap with one finger on the left and one on the right, or a drag motion starting on the left side and moving to the right. However, single taps on the right 1/4, or two-finger taps or gestures that occur solely in the right 1/4, do not work at all. I'm curious why the right 1/4 of the pad is being treated specially...

  2. When I'm typing on the keyboard, I'll occasionally let one of my palms drop and touch the trackpad. In Mac OS X, there was a setting to ignore input from the trackpad during typing, and it worked well. In Fedora, it doesn't seem to work reliably. Supposedly, this feature is enabled for my trackpad:

    Disable-w-typing: enabled

Or at least, I assume that's what it means. Is Fedora encouraging me to practice better hand posture, or is there some way I can adjust the sensitivity of this feature? This one is driving me the craziest by far - I've had to recover five or six times from such mishaps just while writing this post!

  1. libinput seems to think my touchpad is 110.45x82.14mm. However, my touchpad is actually about 100x50mm. The bigger dimension sounds more like the large trackpad on newer models of MacBook. I'm wondering if this could be ausing any of the problems mentioned above, and if so, how can I adjust it?

Thanks for any input you can provide!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-07-06 23:20:59 -0500

aeperezt gravatar image

No sure if this will help, but it solve my touch pad issues https://major.io/2016/07/05/bring-bac... which looks like the same as yours.

edit flag offensive delete link more

Comments

note that the snippet listed there only works when there is a (separate) snippet forcing the synaptics driver to the touchpad or the xorg-x11-drv-libinput driver is removed.

whot gravatar imagewhot ( 2016-07-18 01:22:55 -0500 )edit
0

answered 2016-07-18 01:24:58 -0500

whot gravatar image

The left/right edges on the touchpad are used for palm detection,see http://wayland.freedesktop.org/libinp... but those zones should only be 5% of the touchpad. Together with the other issues you describe it looks like you're just seeing a bug (or multiple). Please file a bug and assign it to me, thanks.

edit flag offensive delete link more

Comments

prwood gravatar imageprwood ( 2016-07-19 13:26:32 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-07-06 23:07:00 -0500

Seen: 1,640 times

Last updated: Jul 18 '16