Ask Your Question
5

F24 error: can't find command 'linux'?

asked 2016-07-04 21:17:33 -0500

jvegas gravatar image

updated 2016-07-07 16:44:41 -0500

EDITED, second time to reflect new information the problem is caused by the 30_os_prober script which is used by Anaconda in installation. It also happens each time the grub2-mkconfig command is used in updating Grub.

EDITED, to reflect the real nature of the problem. The original post is listed below this edit. The real problem is the Anaconda is using the commands linuxand initrd to start any OS other than Fedora 24. The correct command are linuxefi and initrdefi. Now that I have identified the real problem, maybe someone can help me fix this. Each time grub is updated, the error will occur again.

Original post starts here.

Fedora 24 fresh install - After installing Fedora 24 and updating Grub files with

> sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

None of my other OS's will boot correctly. If F24 bootloader is used only F24 boots, same CentOS. I have Ubuntu 16.04, and Mint Cinnamon installed. Ubuntu had always been my "GoTo" OS until I tried the latest versions of Fedora. I prefer Fedora to all other OS's.

My HDD is partioned with 8 partitions, as follows:

sda1  /boot/efi
sda2 Ubuntu 16.04
sda3 swap
sda4 Data ##(used for symlinks to Documents, Downloads, Music and PIctures folders for all OS's
sda5 Linux Mint Cinnamon
sda7 CentOS
sda8 Fedora 24

The only bootloader that works correctly is Ubuntu but it does not support quiet boot for other OS's Fedora and CentOS bootloaders will correctly boot only F24 or CentOS depending on which one created the bootloader.

When selecting other OS's the boot process stops with two error messages:

error:  can't find command 'linux'
error:  can't find command 'initrd'

After examining all of the grub2 config files, they appear to be identifying the HDD and Partitions correctly. I have spent several hours scouring the Wiki pages on Grub2 and all of the supporting files: /etc/default/grub and all files used to make grub.cfg including 00_headers,10_linux, 30_os-prober_proxy, 40_custom and 41_custom.

Obviously, I do not have a clue as to why this is happening. For now, I am using the Ubuntu bootloader, but I would like to do away with Ubuntu and Mint to free of those partitions to be used for additional storage.

Can anyone help with this issue?

`

edit retag flag offensive close merge delete

Comments

@skytux would you have any thoughts on this problem?

jvegas gravatar imagejvegas ( 2016-07-05 10:38:06 -0500 )edit
1

Hi @jvegas! Well, I never used EFI before, so not too much experience here, but why is it using linux instead of linuxefi? I see you have an EFI partition...

skytux gravatar imageskytux ( 2016-07-05 11:35:06 -0500 )edit

@skytux That's part of my dilemma. It appears that when grub.cfg is generated for any OS other than Fedora 24, Anaconda just assumes no EFI. At least that is what it looks like to me. I think it may be a bug, but was waiting for an answer from someone who knows way more about Grub2 and Anaconda than I do. Thanks for responding.

jvegas gravatar imagejvegas ( 2016-07-05 11:57:57 -0500 )edit

I see... well, hope you find an answer asap, and sorry for not being able to help you more. Good luck!

skytux gravatar imageskytux ( 2016-07-05 13:40:39 -0500 )edit

@skytux Your question sparked and idea. The key was that Anaconda is assuming BIOS version commands. I got it to run, won't say how here, to avoid all the conversation over methodology, risks, etc. But, the next time I update the grub file with Fedora and Anaconda, it will produce the same error. Wonder if I should file a bug?

jvegas gravatar imagejvegas ( 2016-07-05 14:07:04 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2016-07-06 00:14:24 -0500

cmurf gravatar image

updated 2016-07-06 00:15:38 -0500

This sounds like a problem in the Fedora build of GRUB. grub2-mkconfig should create grub.cfg with linuxefi and initrdefi on UEFi systems, and linux16 and initrd16 on BIOS. If that's not happening, it's a bug.

edit flag offensive delete link more

Comments

Thanks, @cmurf, I filed the bug earlier here 1353026

jvegas gravatar imagejvegas ( 2016-07-06 01:25:11 -0500 )edit

This post sounds as if it could have been written by me. Exact same issue. Exact same error message(s). And, just like the OP, I'm using the Ubuntu (Mate) bootloader in the interim.

Glenn gravatar imageGlenn ( 2016-07-07 17:22:29 -0500 )edit

Hopefully, @Glenn, they will have a fix for us some time in the near future. Hope they get it done sooner than later, for all of us with this issue,

jvegas gravatar imagejvegas ( 2016-07-07 17:27:42 -0500 )edit

In my case spotted after a windows 10 installation. I were unable to regenerate my grub.cfg from a live cd without this error.

Editing manually my f24 entry with the right name (linuxefi and initdefi) from grub2 menu was required to be able to start on fedora.

After that follow this howto solves this issue definitively

nicofonk gravatar imagenicofonk ( 2016-10-28 07:01:53 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2016-07-04 21:17:33 -0500

Seen: 8,686 times

Last updated: Jul 07 '16