Ask Your Question
1

Windows 8 not showing up in GRUB menu

asked 2012-12-31 21:53:12 -0500

icee3x3 gravatar image

updated 2013-01-01 04:30:43 -0500

hhlp gravatar image

Ok so my computer is pretty new and has a UEFI setup. I have secure boot off, fast boot off, and am booting in Legacy mode. I got Fedora 17 to install and now it is set up and working correctly, however I can no longer acces my windows 8. If I go to files in Fedora i can still see all my data from windows on my hard drive, and I would just like to have the ability to access both Fedora and Windows 8, help would be greatly appreciated! The results from fdisk -l are as follows:

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x377e5c45

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1  1465149167   732574583+  ee  GPT
Partition 1 does not start on physical sector boundary.

Disk /dev/mapper/vg_isaac-lv_swap: 7784 MB, 7784628224 bytes
255 heads, 63 sectors/track, 946 cylinders, total 15204352 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/mapper/vg_isaac-lv_root: 7784 MB, 7784628224 bytes
255 heads, 63 sectors/track, 946 cylinders, total 15204352 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
3

answered 2013-01-13 00:44:56 -0500

Rahul Bhadana gravatar image

grub2-mkconfig -o /boot/grub2/grub.cfg

edit flag offensive delete link more

Comments

Seriously? Repeating the answer, two weeks later?

randomuser gravatar imagerandomuser ( 2013-01-13 16:37:30 -0500 )edit
1

answered 2013-09-17 11:24:55 -0500

gaurav9 gravatar image

As you have UEFI setup for windows 8 .you have to search where your windows 8 bootmgr files stored .
Psst! fdisk command doesn't work for gpt partitioning scheme use gdisk command for that

yum install gdisk dosfstools

then disable Grub2 OS prober

echo GRUB_DISABLE_OS_PROBER=true >> /etc/default/grub

Establish the EFI boot partition holding the Windows boot manager and probe it for string hints search parameter (in my case it was: "/efi/Boot/bootx64.efi". I found lots of examples pointing to "/boot/efi/EFI/Microsoft/Boot/bootmgfw.efi". Note that, in fedora, the command for this is grub2-probe. Many examples online had grub-probe. This was confusing at first.

grub2-probe --target=hints_string /efi/Boot/bootx64.efi

or

grub2-probe --target=hints_string /efi/EFI/Microsoft/Boot/bootmgfw.efi

Create a custom menuentry for Win-8 UEFI-GPT system in "/etc/grub.d/40_custom" and add the results of the above command on the search line. It will look like the following:

menuentry "Microsoft Windows x86_64 UEFI-GPT" {
insmod part_gpt
insmod fat
insmod search_fs_uuid
insmod chain
search --fs-uuid --no-floppy --set=root <insert ouput="" from="" grub2-probe="" here="">
chainloader /efi/Boot/bootx64.efi
}

or

menuentry "Microsoft Windows x86_64 UEFI-GPT" {
insmod part_gpt
insmod fat
insmod search_fs_uuid
insmod chain
search --fs-uuid --no-floppy --set=root <insert ouput="" from="" grub2-probe="" here="">
chainloader /efi/EFI/Microsoft/Boot/bootmgfw.efi
}

and then enter
grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

edit flag offensive delete link more
0

answered 2013-09-12 22:00:30 -0500

pcm314 gravatar image

I run that command and is still not able to find Windows 8, it found fedora,and ubuntu(backtrack) as well, but no W8. What can I do?

edit flag offensive delete link more
0

answered 2013-01-01 14:34:20 -0500

Try rescanning your system for bootable systems and creating a new grub config:

# grub2-mkconfig -o /boot/grub2/grub.cfg

Read on for more information on grub:

edit flag offensive delete link more
0

answered 2013-04-13 14:28:02 -0500

suneal45 gravatar image

i don't get it.Mine still displays error!

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-12-31 21:53:12 -0500

Seen: 7,125 times

Last updated: Sep 17 '13