Ask Your Question
0

Need help regarding intel_iommu=off in kernel cmdline

asked 2016-07-01 09:09:39 -0500

pankajkb gravatar image

Done the following things to verify whether intel_iommu=off is needed or not :-

  1. When intel_iommu=off is there in /etc/default/grub and /boot/grub2/grub.cfg, then when crash is triggered in interrupt handling , vmcore gets generated , but system is not rebooting properly. System needs hard reboot
  2. When intel_iommu=off is not there in /etc/default/grub and /boot/grub2/grub.cfg, then when crash is triggered in interrupt handling , vmcore gets generated , system reboots properly.

Can you please tell what intel_iommu=off does ?

Please guide !!!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-07-01 10:08:54 -0500

intel_iommu is the kernel parameter used to enable or disable support for the Input-Output Memory Management Unit. It is a device built into some motherboards which is used by processors that support it to direct I/O to physical addresses. It can be used in GNU/Linux virtualization solutions, such as KVM, to perform PCI device passthrough so that guest domains (virtual machines) have direct access to the hardware (such as graphics cards or SATA bus devices) which would otherwise be provided to the guest with greater necessary mediation by the hypervisor.

That answers your question.

But, what you probably need to know in addition is why explicitly disabling your kernel's support for the Intel IOMMU device is affecting your situation here. To help, I need a little clarification: when you say "system needs hard reboot" or "system reboots properly", are you talking about a host or a guest domain? Also: are you making use of PCI device passthrough in your virtualization efforts?

edit flag offensive delete link more

Comments

I am using the kdump service. When host system crashes due to panic in interrupt handling, kdump utility tries to capture the vmcore and restart the system. But, system reboot is not happening properly. So, I have to do the hard reboot. (System here is Gigabyte Brix having 4.0.4.fc22.x86_64 kernel).

pankajkb gravatar imagepankajkb ( 2016-07-04 00:37:35 -0500 )edit

Woah - why are you so far back in kernel versions? I make rather robust use of Fedora as a virtualization platform, myself, and it's going to be hard to troubleshoot the issue without updating you to the latest version of the available software so as to rule out the possibility that you're running into bugs which have been solved.

So, first, I say update your Fedora system - is there a reason you have not done this?

Second, have you checked the /var/log/libvirt/qemu/ directory for your guest domain's log file to see if anything helpful is in there? How about your system journal?

bitwiseoperator gravatar imagebitwiseoperator ( 2016-07-04 11:23:32 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-07-01 09:09:39 -0500

Seen: 4,267 times

Last updated: Jul 01 '16