Fedora 24 and WiFi auto start after boot

asked 2016-06-29 18:38:58 -0500

gonebush gravatar image

I recently upgraded to Fedora 24 and I'm having problems getting the wireless interface to start automatically after a boot. The interface will start automatically only if the ethernet connection is conntected to the router.

The following is the contents of the file /etc/sysconfig/network-scripts/ifcfg-<my ssid="">.

HWADDR=F0:7B: CB:3D:AC:11 <--- inserted space because colon-C is a code for a smiley
ESSID="<my ssid>"
MODE=Managed
KEY_MGMT=WPA-PSK
WPA_PSK_FLAGS=user
TYPE=Wireless
BOOTPROTO=none
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
IPV6_ADDR_GEN_MODE=stable-privacy
NAME=<my ssid>
UUID=05bf04b9-91ae-4083-a82a-6b59aeaa3b9c
ONBOOT=yes
DNS1=127.0.0.1
MAC_ADDRESS_RANDOMIZATION=default
IPADDR=192.168.0.10
PREFIX=24
GATEWAY=192.168.0.1
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes

I manually created the file /etc/sysconfig/network-scripts/keys-<my ssid="">, it is as follows:

WPA_PSK='<my password>'

Any clues as to why this is happening?

Cheers, Kev

edit retag flag offensive close merge delete

Comments

Hello, same problem here. Did you solve it? I have to connect a LAN cable just to have WiFi, thanks in advance

SnydersGC gravatar imageSnydersGC ( 2016-08-01 12:59:09 -0500 )edit