Ask Your Question
0

'gem install sqlite3' error

asked 2016-06-28 14:48:20 -0500

majid gravatar image

When running the gem install sqlite3 command on F24 I experience the following error message:

    current directory: /usr/local/share/gems/gems/sqlite3-1.3.11/ext/sqlite3/usr/bin/ruby -r ./siteconf20160629-3431-kd6d1g.rb extconf.rb --with-sqlite3-include=/usr/include/sqlite3x --with-sqlite3-dir=/usr/bin/sqlite3 --with-sqlite3-lib=/usr/lib64/libsqlite3x.sochecking for sqlite3.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-06-28 15:55:49 -0500

aeperezt gravatar image

You are using gem install to install sqlite3 so you need to have installed sqlite-devel package

sudo dnf install sqlite-devel sqlite-libs ruby-devel

That package will install sqlite headers and libraries, also added ruby-devel only incase you have not installed.

You can also install sqlite3 gem with native Fedora ruby support.

sudo dnf install rubygem-sqlite3

Good luck

edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-06-28 14:48:20 -0500

Seen: 721 times

Last updated: Jun 28 '16