Ask Your Question

Can't boot into fedora cause of selinux policy

asked 2012-05-01 13:37:41 -0500

Lynn gravatar image

updated 2014-09-30 15:10:22 -0500

mether gravatar image

I just changed my selinux policy, now i can't boot into fedora. It goes down all the files while booting up then freezes at could not open policy file /etc/selinux/mls/policy/policy.26. What can I do? please give me several suggestions.

I tried booting in as single-user mode didn't work.

I booted into the live disk and went into /etc/selinux/config disabled selinux and didn't work. What am I doing wrong?

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted

answered 2013-05-18 10:35:11 -0500

jsl gravatar image

My problem was resolved by disabling SElinux with kernel command line option "selinux=0".

edit flag offensive delete link more

answered 2013-08-07 06:37:46 -0500

none gravatar image

I suggest that you set SELinux in permissive mode /etc/selinux/config, touch /.autorelabel, reboot, and post here your ausearch -m avc | tail.

edit flag offensive delete link more

answered 2012-05-01 14:36:29 -0500

ztank1013 gravatar image

updated 2012-05-01 17:10:47 -0500

If you haven't tried it already I would boot in single-user mode then set selinux policy to disabled and reboot.

Instructions to start in single-user mode can be found here:

Edit: If it doesn't work you may try to boot with a live distro, mount the file system and try to change the selinux policy that way.

edit flag offensive delete link more

answered 2014-01-24 13:40:41 -0500

deusdara gravatar image

updated 2014-01-24 13:43:04 -0500


If you have selinux enabled in enforcing mode (default) all future updates will fail unless you run.

setenforce 0

yum clean expire-cache

yum update selinux-policy*

setenforce 1

link to the selinux issue

edit flag offensive delete link more


You do understand, I hope, that the question was asked May 1, 2012?

sideburns gravatar imagesideburns ( 2014-01-24 14:59:20 -0500 )edit

very helpful , solved my selinux freeze in Fedora 20

danfalos gravatar imagedanfalos ( 2014-04-29 03:40:42 -0500 )edit

answered 2014-01-24 10:30:05 -0500

I have a simular issue. To solve it, you should boot your system with enforcing=1 as an kernel parameter.

After you have a running system you should find out which packages you have accidently erased. If you can install all this packages your system should be fully functionally. This mean, that you should be able to start your system in enforcing mode.

edit flag offensive delete link more

Question Tools


Asked: 2012-05-01 13:37:41 -0500

Seen: 10,128 times

Last updated: Jan 24 '14