Ask Your Question
1

My Laptop with Fedora 23 can't see all Wireless Networks

asked 2016-06-16 13:25:15 -0500

How can I fix this? on lspci | grep net I have this output: 02:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RT8102E PCI Express Fast Ethernet controller (rev 06). On Windows 10 I can see and use all the wireless networks.

edit retag flag offensive close merge delete

Comments

That is your network card you need to do

lspci |grep Wire

To get you wireless information so we can advice you better.

aeperezt gravatar imageaeperezt ( 2016-06-16 13:38:11 -0500 )edit

03:00.0 Network Controller: Realtek Semiconductor Co., Ltd. RTL8273BE PCIe Wireless Network Adaptor

George Alexander gravatar imageGeorge Alexander ( 2016-06-16 13:39:18 -0500 )edit

I just checked and the connection via LAN cable doesn't work either.

George Alexander gravatar imageGeorge Alexander ( 2016-06-16 13:40:16 -0500 )edit

What version of Fedora are you running and how did you install it? Which desktop environment are you using (Gnome, KDE, etc.)?

Run sudo journalctl -f --all in a terminal window then plug in the network cable to see what happens.

ssieb gravatar imagessieb ( 2016-06-16 16:03:36 -0500 )edit

Did you restart NetworkManager after connecting the cable, if you nic has a led indicator it start when you connected your network cable. Make sure you have installed NetworkManager-wifi on you pc

rpm -qa NetworkManager*
aeperezt gravatar imageaeperezt ( 2016-06-16 16:53:47 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-06-17 03:46:43 -0500

updated 2016-06-17 05:29:18 -0500

hhlp gravatar image

I am running Gnome. When I run sudo journalctl -f --all , I get

[george@192-168-0-105 ~]$ sudo journalctl -f --all
-- Logs begin at Thu 2016-06-16 16:54:46 EDT. --
Jun 17 04:41:22 192-168-0-105.rdsnet.ro systemd[1]: Started Fingerprint Authentication Daemon.
Jun 17 04:41:24 192-168-0-105.rdsnet.ro audit[2612]: USER_AUTH pid=2612 uid=1000 auid=1000 ses=1 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='op=PAM:authentication grantors=pam_unix acct="george" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/0 res=success'
Jun 17 04:41:24 192-168-0-105.rdsnet.ro audit[2612]: USER_ACCT pid=2612 uid=1000 auid=1000 ses=1 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='op=PAM:accounting grantors=pam_unix,pam_localuser acct="george" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/0 res=success'
Jun 17 04:41:24 192-168-0-105.rdsnet.ro audit[2612]: USER_CMD pid=2612 uid=1000 auid=1000 ses=1 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='cwd="/home/george" cmd=6A6F75726E616C6374202D66202D2D616C6C terminal=pts/0 res=failed'
Jun 17 04:41:31 192-168-0-105.rdsnet.ro sudo[2625]:   george : TTY=pts/0 ; PWD=/home/george ; USER=root ; COMMAND=/bin/journalctl -f --all
Jun 17 04:41:31 192-168-0-105.rdsnet.ro audit[2625]: USER_CMD pid=2625 uid=1000 auid=1000 ses=1 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='cwd="/home/george" cmd=6A6F75726E616C63746C202D66202D2D616C6C terminal=pts/0 res=success'
Jun 17 04:41:31 192-168-0-105.rdsnet.ro audit[2625]: CRED_REFR pid=2625 uid=0 auid=1000 ses=1 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='op=PAM:setcred grantors=pam_env,pam_fprintd acct="root" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/0 res=success'
Jun 17 04:41:31 192-168-0-105.rdsnet.ro sudo[2625]: pam_systemd(sudo:session): Cannot create session: Already running in a session
Jun 17 04:41:31 192-168-0-105.rdsnet.ro sudo[2625]: pam_unix(sudo:session): session opened for user root by (uid=0)
Jun 17 04:41:31 192-168-0-105.rdsnet.ro audit[2625]: USER_START pid=2625 uid=0 auid=1000 ses=1 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='op=PAM:session_open grantors=pam_keyinit,pam_limits,pam_keyinit,pam_limits,pam_systemd,pam_unix acct="root" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/0 res=success'

Jun 17 04:41:52 192-168-0-105.rdsnet.ro audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fprintd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'`,

and then it stops.

When I run rpm -qa NetworkManager*, I get this:

[george@192-168-0-105 ~]$ rpm -qa NetworkManager*
NetworkManager-openconnect-1.0.8-1.fc23.x86_64
NetworkManager-libnm-1.0.12-2.fc23.x86_64
NetworkManager-wifi-1.0.12-2.fc23.x86_64
NetworkManager-vpnc-1.0.8-1.fc23.x86_64
NetworkManager-vpnc-gnome-1.0.8-1.fc23.x86_64
NetworkManager-adsl-1.0.12-2.fc23.x86_64
NetworkManager-pptp-1.1.0-2.20150428git695d4f2.fc23.x86_64
NetworkManager-pptp-gnome-1.1.0-2.20150428git695d4f2.fc23.x86_64
NetworkManager-config-connectivity-fedora-1.0.12-2.fc23.x86_64
NetworkManager-1.0.12-2.fc23.x86_64
NetworkManager-bluetooth-1.0.12-2.fc23.x86_64
NetworkManager-openvpn-1.0.8-2.fc23.x86_64
NetworkManager-team-1.0.12-2.fc23.x86_64
NetworkManager-openvpn-gnome-1.0.8-2 ...
(more)
edit flag offensive delete link more

Comments

I managed to fix it by modifying router's settings and after a few restarts. Now it's working just fine. I have no clue why it didn't worked from the beginning as it should.

George Alexander gravatar imageGeorge Alexander ( 2016-06-17 07:17:04 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-06-16 13:25:15 -0500

Seen: 137 times

Last updated: Jun 17 '16