Ask Your Question
4

How can I change default Operating System in start up boot menu?

asked 2012-06-16 05:44:25 -0500

sabi gravatar image

updated 2017-01-13 15:23:01 -0500

mattdm gravatar image

How can I change default Operating System in start up boot menu? It is Fedora 17 now and I want to set it on Win 7.

edit retag flag offensive close merge delete

Comments

hhlp gravatar imagehhlp ( 2012-06-16 11:28:41 -0500 )edit

Unfortunatly it did not work for me, after i've gone through the process of setting windows 7 to a default, after doing these commands, my fedora crashed and i couln't login onto desktop anymore :(. I get sendmain starting, hangs there and that's it, no splash sreen shows up, nothing! Any one can tell, if there is another way to fix the boot order, like a graphical interface? Thanks!

xcomb gravatar imagexcomb ( 2013-11-05 00:20:06 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
7

answered 2012-06-18 09:36:07 -0500

Akshay gravatar image

updated 2012-06-18 09:37:07 -0500

In a terminal type:

grep menuentry /boot/grub2/grub.cfg

This will display all your grub entries

Highlight the entry you want to default to - for example Windows 7 (loader) (on /dev/sda1) Right click and choose copy

Type

gedit /etc/default/grub

Change the entry

GRUB_DEFAULT=0

to

GRUB_DEFAULT="Windows 7 (loader) (on /dev/sda1)"

i.e. paste the entry you want (including the quotes)

Save, then type

grub2-mkconfig -o /boot/grub2/grub.cfg
edit flag offensive delete link more

Comments

Seems like you are trying to run gedit as root. For gedit to work this way, use "gedit -s /etc/default/grub"

This disables the dbus check so it can be used as root.

LooseWire29710 gravatar imageLooseWire29710 ( 2012-12-28 16:26:09 -0500 )edit

when i try to save by command grub2-mkconfig -o /boot/grub2/grub.cfg.....i am getting no such file found.

Ajay gravatar imageAjay ( 2013-02-28 21:50:11 -0500 )edit

'gedit' isn't really the ideal command to be editing files as root, even if you can disable the dbus interface. Try a simple editor like nano, which has on-screen instructions.

wquine gravatar imagewquine ( 2013-08-06 20:38:01 -0500 )edit

Maybe you had add an extra space after the plus sign, just delete it and everything works fine.

salah gravatar imagesalah ( 2014-07-11 13:31:35 -0500 )edit

Thanks, saved my time

pal1 gravatar imagepal1 ( 2016-02-17 04:08:49 -0500 )edit
-1

answered 2013-08-06 20:19:16 -0500

First Move to SuperUser

su

Then search the grub menu entries of your grub

grep menuentry /boot/grub2/grub.cfg

Now edit the grub config by an editor

vi /etc/default/grub

Change the timeout and the GRUB_DEFAULT=0 to GRUB_DEFAULT="Windows 7 (loader) (on /dev/sda1)" The "Windows 7 (loader) (on /dev/sda1)" thing is for Windows 7. You can find your text from the grep menuentry /boot/grub2/grub.cfg

Now save and close form text editor and type the command

grub2-mkconfig -o /boot/grub2/grub.cfg

You are all Done!!

edit flag offensive delete link more

Comments

Other than the timeout, how does this differ from the existing answer? Why change the timeout, anyway?

randomuser gravatar imagerandomuser ( 2013-08-06 21:20:08 -0500 )edit

Didn't get to try this

pal1 gravatar imagepal1 ( 2016-02-17 04:09:21 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2012-06-16 05:44:25 -0500

Seen: 123,714 times

Last updated: Nov 05 '13