Ask Your Question
0

Sending Mail does not work

asked 2012-03-25 10:30:08 -0500

mindjoy gravatar image

Using Fedora 16, I'd like to use my mail client software (i.e. SeaMonkey Mail) to send mail. However, if I set it up to to use my provider's SMTP server on port 25, it times out every time it attempts to connect to it. The same setup works fine from Windows which runs on the same machine in dual boot.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-07-06 19:38:05 -0500

mindjoy gravatar image

updated 2012-07-14 12:10:48 -0500

I thought I figured out what's going on: my ISP changed the port where their SMTP server is listening to 26 (can you imagine that)?! However, sending mail on Windows still works fine on port 25 on the same box!?

Update: My hosting provider clarified that the server actually works on both ports 25 and 26. Therefore, it seems that something in Fedora (and also in Arch Linux, which I switched to) blocks port 25.

It would be great if you people could comment here on how you might have resolved this issue on Fedora, although I haven't seen anybody mentioned having the same problem. However, I would really like to know what's going on in Linux regarding SMTP port 25. The last time I used OpenSUSE, the port 25 was working fine. Perhaps everybody uses Webmail nowadays and does not care about SMTP servers anymore. Please let me know what you think.

edit flag offensive delete link more
0

answered 2012-03-26 06:21:33 -0500

FranciscoD_ gravatar image

Port 25 is the standard smtp port. From my understanding, this means that an smtp server running on your machine will use port 25 to send out email. When you want to use another smtp server (I use gmail for instance), you need to specify the configuration the service provider gives you. (Again, Gmail uses port 465). Please contact your email provider and ask them for the correct settings required to use their smtp server. Or check the windows configuration. It really shouldn't be using port 25 to connect to your providers smtp server IMO.

edit flag offensive delete link more

Comments

I really don't know. I use evolution, and it works like a charm.

FranciscoD_ gravatar imageFranciscoD_ ( 2012-03-27 00:30:05 -0500 )edit

Question Tools

Stats

Asked: 2012-03-25 10:30:08 -0500

Seen: 1,006 times

Last updated: Jul 14 '12