Ask Your Question
1

(Solved) WD USB drive mounts Read Only

asked 2012-04-24 13:40:19 -0600

Phlintlock gravatar image

updated 2012-04-25 18:36:26 -0600

I'm currently running Fedora 15 along with Win 7. I left my USB drive plugged in when I booted to Win, now in Fedora the drive will mount as "read only". How do I get it back to "read/write"?

Thanks, John

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2012-04-24 15:55:01 -0600

ztank1013 gravatar image

Run the following as root from the command line:

mount -o remount,rw <device> <path/to/mount/point>

Substitute <device> with something like /dev/sdb1 or similar and <path/to/mount/point> with an existing empty directory (like /mnt).

edit flag offensive delete link more

Comments

@ztank1013 i don't think its good to mess with automounter

Akshay gravatar imageAkshay ( 2012-04-24 19:23:03 -0600 )edit
0

answered 2015-01-15 06:13:16 -0600

I was also having the same issue & I solve problem by using fsck command..

I found the solution here http://anotation.com/read-only-usb-drive-in-fedora-resolve-issue-without-formatting

edit flag offensive delete link more
0

answered 2018-04-07 06:36:57 -0600

jkalina gravatar image

I had the same issue after incorect formating USB from Disks utility:

While the USB was wiped using dd, I had chosen Format partition from the bottom menu in the bottom of Volumes graph. This created NTFS filesystem directly in /dev/sdb - without partitions system! As following, this filesystem was mounted readonly, everytime the USB was inserted into the computer.

The resolution is to use Format Disk... in the top right menu in Disks utility to put MBR (or GPT) to the disk. As following, you can choose the blank space in the volume and in bottom menu use Format partition... to create FAT/NTFS/etc filesystem in /dev/sdb1.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-04-24 13:40:19 -0600

Seen: 26,152 times

Last updated: Jan 15 '15