Ask Your Question
0

Some MP3 players are failing [closed]

asked 2016-05-23 08:11:45 -0500

Been using Clementine for quite a while now and everything always ran smoothly. All of the sudden Clementine started complaining about missing plugins. Tried Yarock, which also fails to play. VLC and XMMS are working good.

Was Gstreamer broken in the recent updates? How can I fix this?

Here's Clementine output:

10:07:45.598 WARN  unknown                          libpng warning: iCCP: known incorrect sRGB profile 
10:07:45.645 WARN  unknown                          QxtGlobalShortcut failed to register: "Media Next"  
10:07:45.645 WARN  unknown                          QxtGlobalShortcut failed to register: "Media Play"  
10:07:45.645 WARN  unknown                          QxtGlobalShortcut failed to register: "Media Previous"  
10:07:45.645 WARN  unknown                          QxtGlobalShortcut failed to register: "Media Stop"  
10:07:45.780 WARN  unknown                          QPainter::begin: Paint device returned engine == 0, type: 2 
10:07:45.917 WARN  unknown                          Object::connect: No such signal QtSingleApplication::messageReceived(QByteArray) 
10:07:45.917 WARN  unknown                          Object::connect:  (sender name:   'clementine') 
10:07:45.917 WARN  unknown                          Object::connect:  (receiver name: 'MainWindow') 
10:07:57.348 WARN  unknown                          QPainter::begin: Paint device returned engine == 0, type: 2 
10:07:57.348 WARN  unknown                          QPainter::translate: Painter not active 
10:07:57.348 WARN  unknown                          QPainter::save: Painter not active 
10:07:57.447 WARN  unknown                          QPainter::pen: Painter not active 
10:07:57.447 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.447 WARN  unknown                          QPainter::pen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::pen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::pen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::setPen: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::restore: Unbalanced save/restore 
10:07:57.448 WARN  unknown                          QPainter::translate: Painter not active 
10:07:57.448 WARN  unknown                          QPainter::end: Painter not active, aborted 
10:07:57.579 WARN  unknown                          QTimeLine::start: already running 
10:07:57.596 WARN  unknown                          QTimeLine::start: already running

And here is Yarock output:

** Message: PackageKit: xid = 20971524
** Message: PackageKit: desktop_id = (null)
** Message: PackageKit: Codec nice name: MPEG-1 Layer 3 (MP3) decoder
** Message: PackageKit: ignoring field named parsed
** Message: PackageKit: field is: mpegversion, type: gint
** Message: PackageKit: field is: layer, type: gint
** Message: PackageKit: structure: gstreamer1(decoder-audio/mpeg)(mpegversion=1)(layer=3)()(64bit)
** Message: PackageKit: Did not install codec: GDBus.Error:org.freedesktop.DBus.Error.UnknownInterface: No such interface 'org.freedesktop.PackageKit.Modify2' at object path '/org/freedesktop/PackageKit'
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by davidva
close date 2016-05-28 02:20:15.684579

Comments

1

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-05-23 08:32:32 -0500

Alright, so I went crazy and did a sudo dnf install gstreamer* All working now.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-05-23 08:11:45 -0500

Seen: 394 times

Last updated: May 23 '16