Ask Your Question

gnome-shell; High CPU Usage [closed]

asked 2012-10-24 23:27:07 -0500

Chandies gravatar image

updated 2015-06-02 03:25:09 -0500

This weekend I migrated to a new laptop, an Acer Aspire V3-551-8887 (4gb RAM, AMD A8-4500m quad core). With a new laptop, I thought I'd make the jump to Fedora 17 (F16 was on my previous laptop).

All worked well after the DVD install and applying all pending updates, but I notice that both Top and System Monitor show abnormally high CPU usage, 100 - 150%, or more.

The process is tagged as gnome-shell, but I am not very experienced at looking u'under-the-hood' in linux to get further information.

Any ideas? I'm sure there's more information I can give you, I just don't what would be needed or how to obtain it, yet.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by florian
close date 2017-07-07 08:24:12.779629


If you are working in a VM environment you should activate graphics acceleration (like 3D)

inlaw gravatar imageinlaw ( 2017-12-20 10:43:12 -0500 )edit

@inlaw, I'm using a Virtualbox VM and enabling/disabling 3d acceleration hasn't had any visible change on the problem. The answer by Joris, to disable the "Background logo" extension has helped though.

90634 gravatar image90634 ( 2018-11-22 22:11:10 -0500 )edit

4 Answers

Sort by » oldest newest most voted

answered 2017-07-07 07:02:39 -0500

noblesw gravatar image

I realize that this post is old, but I am having the same problem using Fedora 25 Server. I installed the gnome-tweak-tool, but under Extensions, I have no extension labeled Background Logo. Brand new box, but it is acting like it's 30 years old because CPU usage is at 98%

edit flag offensive delete link more


Please open a new question.

florian gravatar imageflorian ( 2017-07-07 08:23:46 -0500 )edit

answered 2013-03-02 03:44:36 -0500

Bucic gravatar image

You should re-check it with system freshly booted and no additional programs fired up to make sure Gnome Shell isn't forced to do some heavy redrawing on some windows (e.g. few opened video players). If the situation still persists you should submit a bug report

Make sure to go through the following article first

edit flag offensive delete link more

answered 2015-03-25 12:19:47 -0500

Joris gravatar image

I've had this problem as well. My solution was to disable the extention "Background Logo", which draws the fedora logo on top of your background.

My CPU usage is back to 2% right now.

To disable the extention: Install gnome-tweak-tool

sudo yum install gnome-tweak-tool

Start the tweak tool and disable the extention "Background Logo" in the overview "Extentions"

edit flag offensive delete link more


This did it for me! Thanks so much. And it's not even removable via the panel, so I could only disable it. Weak.

Daniel Quinn gravatar imageDaniel Quinn ( 2015-04-09 05:25:25 -0500 )edit

I cannot upvote the answer, but it helped me to, with Fedora 28 on a Virtualbox VM. I wonder, why the question was marked as not relevant.

90634 gravatar image90634 ( 2018-11-22 22:07:18 -0500 )edit

answered 2016-02-02 23:30:00 -0500

bodi gravatar image

My laptop (Fedora 23) had a similar problem, but I realised that it only appeared when connected to a secondary screen. The solution was via “Settings” → “Displays” → “Arrange Combined Displays” to readjust the relative positioning of the screen areas.

edit flag offensive delete link more

Question Tools


Asked: 2012-10-24 23:27:07 -0500

Seen: 30,343 times

Last updated: Jul 07 '17