Ask Your Question

video tearing in totem

asked 2016-05-19 16:00:18 -0500

wasting_chalk gravatar image

I was playing mp4 videos on totem, and get serious tearing there. However, if I play the same video using google chrome, there is no tearing at all. I was wondering how to solve the tearing in totem.

edit retag flag offensive close merge delete


You need to know a bit more about the audio codec and video format, it is possible that you have missing them or have wrong ones, they work Google Chrome because it includes the audio codecs, so it is ready for any format and codec, while Totem will depend on what you have on your system.

aeperezt gravatar imageaeperezt ( 2016-05-19 16:55:25 -0500 )edit

It's possible we'll be stuck with video tearing for another year or two, because it's apparently an X11 issue. If you choose GNOME with Wayland at the login screen, video tearing won't be a problem. But you'll get different problems (quirky dropdown menus, difficult trackpad movements, etc.) because Wayland isn't quite ready.

jtlinux gravatar imagejtlinux ( 2016-05-20 20:06:20 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2017-12-18 06:46:17 -0500

workman729 gravatar image

Are You using the nvidia divice of that install gnome-shell-extension-disable-unredirect. (gnome-3.26 is just add edit metadata.json file.)

If you're using intel divice, just add the tear free of xorg.conf. AMD divice is use that amd-setting.

Gnome-shell tearing is almost occur video player on the xorg, some divice is not help wayland.

edit flag offensive delete link more

answered 2017-12-18 01:18:26 -0500

lispy gravatar image

updated 2017-12-18 01:23:57 -0500

For me the solution was to change my compositor I switched to compton. You can get is link:here. Even without a config file it will work fine but write a config file that works for you and it will work best.

edit flag offensive delete link more

Question Tools


Asked: 2016-05-19 16:00:18 -0500

Seen: 557 times

Last updated: Dec 18 '17