Ask Your Question

wireshark, work as unprivileged user

asked 2016-05-18 04:11:11 -0500

pblahman gravatar image

Fedora 24 beta, LXQT desktop. Start wireshark as a non SU from lxqt menu system. It can not or will not identify an available interface. If I do "su -" from a console or konsole and execute wireshark from the command line, then wireshark finds available interfaces. How does one configure wireshark or the network interfaces in such a way as to allow wireshark to find interfaces when launched as a non SU.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2016-05-18 13:45:11 -0500

ssieb gravatar image

Add your user to the wireshark group, then login again.

edit flag offensive delete link more


Hello, I'm a new Fedora user and I am running into the same issue. How do you add your user to the wireshark group? I've also tried the command listed below but have had no luck. I appreciate any help provided.

iamthestrain gravatar imageiamthestrain ( 2016-10-29 18:41:56 -0500 )edit

What happened when you tried to run that command? What is the output of id?

ssieb gravatar imagessieb ( 2016-10-31 13:24:02 -0500 )edit

answered 2016-05-19 04:08:50 -0500

hhlp gravatar image

Just type this in terminal :

sudo usermod -a -G wireshark $USER


edit flag offensive delete link more

Question Tools


Asked: 2016-05-18 04:11:11 -0500

Seen: 366 times

Last updated: May 19 '16