Ask Your Question
-1

How can i disable dnf transaction checks?

asked 2016-05-15 07:12:13 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hi All,

This is a 64 bit Fedora 23 system, and I need to install 32 bit gtk alongside 64 bit gtk. The gtk3.i686 install fails with a Transaction Failed error. However the conflicts are mainly man files and docs. I would like to disable transaction check, or force the install. How can I do this?

Error: Transaction check error:
  file /usr/share/doc/gtk3/README from install of gtk3-3.18.9-1.fc23.i686 conflicts with file from package gtk3-3.18.2-1.fc23.x86_64
  file /usr/share/doc/gtk3/NEWS from install of gtk3-3.18.9-1.fc23.i686 conflicts with file from package gtk3-3.18.2-1.fc23.x86_64

Thanks, Ran

edit retag flag offensive close merge delete

Comments

2

You should update your system before installing anything. Do dnf upgrade and then install gtk3.i686.

skytux gravatar imageskytux ( 2016-05-15 13:30:37 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2016-05-15 11:32:59 -0500

genodeftest gravatar image

Don't disable transaction checks. If you would, packages would likely break or destroy your system. They exist for a reason.

In your case it looks like package gtk3 is installed in both x86_64 and i686 version. The x86_64 version is pretty outdated, can you please update it and then try again? If this issue still exists, please file a bug.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-05-15 07:12:13 -0500

Seen: 335 times

Last updated: May 15 '16