Ask Your Question
1

Cannot access "Disk Management" under "System"

asked 2012-11-15 15:36:47 -0500

cva gravatar image

updated 2014-09-29 16:09:18 -0500

mether gravatar image

I try to access Disk Management under System in pull down menus, and get: "There are no filesystems which you are allowed to mount or unmount. Contact your administrator." How do I get around this? I am the only user of this fedora install, and I should have have administrator priviledges.

edit retag flag offensive close merge delete

Comments

Hello I use f-18 with xfce! and try add string nano /etc/passwd with my neme alexa:x:0:0:root:/home/alexa:/bin/bash and it also doesn't work ! How solve this issue?

alexa gravatar imagealexa ( 2013-05-05 16:07:42 -0500 )edit
4

Very bad idea to change your user's UID to 0 (zero), that makes your user the same as ROOT!!!

lrhazi gravatar imagelrhazi ( 2014-01-06 15:01:06 -0500 )edit

True @Irhazi +1. Nice!

abadrinath gravatar imageabadrinath ( 2014-07-21 06:00:40 -0500 )edit

I have this same problem -- there's an entry in the menu for Disk Management, and it's basically unusable. What should happen is that a program starts and asks you for the root password to continue. That doesn't happen here, and there's probably some kind of configuration change that will make this work.

My question: Does anybody know how to make Disk Management in the Fedora menu work?

passthejoe gravatar imagepassthejoe ( 2014-07-21 17:58:22 -0500 )edit

I just figured this out and will answer below.

passthejoe gravatar imagepassthejoe ( 2014-07-21 18:07:15 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
4

answered 2014-07-21 06:53:05 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Please remove the recommendation to change the user ID from 1000+ to zero. This is a big no-no.-no

When Fedora was installed, the install program (Anacanda) asked if you wanted that user to be an administrator. I presume you answered yes.

If you answered yes, that logon has administrator privileges. You are now member of at least two groups, your own group (1000) and the wheel group. Explore group rules etc with the command line instruction

man group, or info group.

Once you are a member of the wheel group, then when you do sudo "secure command", you will be asked for your logon password. and you are ok.

You should take a few minutes to do sudo visudo and look for the line that says NOPASSWD remove the # which is the first character save and exit thereafter sudo xxx will not ask for your logon password.

edit flag offensive delete link more
2

answered 2014-07-21 05:41:20 -0500

You should set up sudo properly that allows your user certain privileges, or use other methods that only allows user to mount filesystem. Regardless of what method you use, you must always be aware of the security implications of your actions. Note for obvious reasons, including breadth and scope, those security implications will not be discussed on this page.


    su -

After typing the above command in your terminal, pressing <\Enter> will prompt you to type in your root password.

Installing and Configuring sudo

As the root user, proceed to install the sudo package

 yum install sudo

After successful installation, edit the configuration for sudo program by typing in your terminal

visudo

To allow your user to execute any commands anywhere, find the line that looks like the following:

root    ALL=(ALL)    ALL

and insert a similar line below it, replacing root with your username.
To input text while using the Vi editor, use the arrow keys to place the cursor below the line that starts with root and hit the i key on your keyboard. Type the following, replacing yourusername with your actual user name:

yourusername    ALL=(ALL)    ALL

However, in most situations this may not be necessary and, therefore, isn't advised unless it proves to be such. An adequate method, and arguably safer, is to simply add your user name to the wheel group and allow members of the wheel group certain permissions. Hit the escape key (ESC) and scroll down to the line that looks like the following

#%wheel ALL=(ALL)    ALL

place the cursor on the # at the beginning of the line and hit x on your keyboard if you want to allow all members of the group wheel to be able to execute any commands anywhere they wish. To give the members only permission to mount/unmount filesystems, place the following below the original line above:

%wheel ALL = /usr/sbin/mount /usr/sbin/umount

Next, execute the following key combination

:wq <Enter>
edit flag offensive delete link more

Comments

The user may also uncomment the line containing NOPASSWD
This is fine, if the computer is a single usere system. If there are multiple users, it is also OK, as the other users are not members of the wheel. group.

lsatenstein gravatar imagelsatenstein ( 2014-07-21 06:55:12 -0500 )edit
1

answered 2014-07-21 18:12:58 -0500

passthejoe gravatar image

In the Fedora menu (at least under Xfce), Applications - System - Disk Management calls the program usermount.

If you want to run usermount, you can so so from a terminal using the su utility. Open a terminal window and type (after the $ prompt):

$ su -c usermount

Then enter the root password when prompted. You will now be in the usermount gui.

If you have sudo installed on your system (and I always recommend it), you can also call usermount with:

$ sudo usermount

Then enter your user password when prompted. If you have sufficient permissions, the GUI program will start.

But if the sudo command doesn't work, and if you do have the root password, the su version will work.

edit flag offensive delete link more

Comments

Doesn't work - sorry.

trol1ed gravatar imagetrol1ed ( 2014-07-22 03:13:38 -0500 )edit

Of course it's working. It's working just fine here. su -c '/usr/bin/usermount' enter root password and the user mount tool must open. At least at my F20 installation, it's opening without problems.

NickTux gravatar imageNickTux ( 2014-07-22 03:45:40 -0500 )edit
0

answered 2014-07-22 04:08:59 -0500

NickTux gravatar image

updated 2014-07-22 04:11:14 -0500

An alternative

I don't really know, why this disk management entry is still there (usermount-gui), and for a new user this is almost unusable.

The new user has to know how to open this tool, as other answers here indicated, the user has to open the tool either from terminal

su -c '/usr/bin/usermount'

followed by the root password, or setting up sudo properly.

The program disks is there (GNOME disks application), and it's working without all this effort. It's working out of the box, and without the need of root privileges or anything, just to open it.

At least, you can see the disks - partitions - mountpoints and other useful staff (like S.M.A.R.T) and performing basic management.

So, leave disk management alone, and when you click the activities button, write: disks and click Enter.

Enjoy Disks.

Be aware that you can create/delete ..etc partitions and external drives, without the need of a root or admin password. This is not a bug, it's a designing feature and you can read about, at the comments, at this bug (notabug) report.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-11-15 15:36:47 -0500

Seen: 4,216 times

Last updated: Jul 22 '14