Ask Your Question
1

How do I get Gnome 3.8 to load my .Xmodmap file?

asked 2012-11-02 11:04:46 -0500

mattdm gravatar image

updated 2013-06-14 09:02:51 -0500

I have an .Xmodmap file with several years of unicode shortcuts and remappings that I've gotten used to over the years. Gnome used to load this — it would pop up a one-time dialog box asking what to do if the file was found.

In Gnome 3.8 (and in 3.6), it is ignored. How can I fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2012-11-27 08:37:02 -0500

sup gravatar image

Run gnome-session-properties and add and entry with command

xmodmap /path/to/your/xmodmap/file

and that should do it. Note that I am on Ubuntu, maybe systemd breaks this as per https://bbs.archlinux.org/viewtopic.php?id=152708

edit flag offensive delete link more

Comments

It still gets forgotten on suspend and resume, unfortunately.

mattdm gravatar imagemattdm ( 2013-01-10 09:42:56 -0500 )edit

Question Tools

Stats

Asked: 2012-11-02 11:04:46 -0500

Seen: 3,793 times

Last updated: Jun 14 '13