Ask Your Question

Fedora 23/24 randomly freezes.

asked 2016-05-11 16:38:57 -0500

jsmccloud gravatar image

I've decided to move from Windows 10 to Fedora but I'm having problems with the Linux OS freezing. I had started with Ubuntu, then Linux Mint, Fedora 23 and now, currently on Fedora 24 beta. All of them freeze but I've decided I like Fedora best and want to stick with that.

I have searched the Internet for solutions and it seems one common problem is having an NVidia graphics card. That I need to manually install the NVidia graphics driver. I have the GTX 660 Ti. I've tried several instructions but I keep getting lost following the terminal commands, where as it will be marked as a solution, not all the commands work for me and I don't understand why.

My hopes is that perhaps a couple of you can help walk me through the process of fixing this, step by step. Hopefully without having to use the terminal, if possible.

If there is another version of Fedora that just works with NVidia cards I'd be happy to give it a try.

If it helps here are my specs.
I7 Intel processor Asrock motherboard 16GB Memory Asus GTX 660 120Gb SSD 3TB HDD

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted

answered 2016-05-11 16:59:56 -0500

sideburns gravatar image

Welcome to ask.fedora. This is a question that's been asked and answered here many times across the years. My personal recommendation is to look at the Fedora Setup Guides at the Fedora Forum, another excellent support site. Just remember that F 24 is still in beta, but the guide for F 23 should work just fine. Let us know how things turn out, and if you need any more help getting the drivers working.

edit flag offensive delete link more


I've been struggling with this for days. Anything I try seems to fail for one reason or another. I've searched the forums and came across this one that I'm trying to do:

In the comments it says I need Rpmfusion repository to install the proprietor nvidia drivers, but I can't even get past getting the repository.

I go to the link here that you gave:

click on rpmfusion for version 23 of fedora but I get an error saying the repository I'm searching for could not be found.

What can I do?

jsmccloud gravatar imagejsmccloud ( 2016-05-11 17:50:43 -0500 )edit

Command line setup failed as well, see below....

[jmccloud@localhost ~]$ su -c 'dnf install$(rpm -E %fedora).noarch.rpm$(rpm -E %fedora).noarch.rpm'
Failed to synchronize cache for repo 'rpmfusion-free-updates', disabling.
Last metadata expiration check: 1:15:21 ago on Wed May 11 14:53:20 2016.
Status code: 404 for
[jmccloud@localhost ~]$
jsmccloud gravatar imagejsmccloud ( 2016-05-11 18:10:29 -0500 )edit

Judging by your original post, you're now on F 24 Beta, and there aren't any appropriate rpmfusion repos yet. My suggestion is to go to the testing mailing list and ask there, as this site isn't really for versions that haven't been released yet.

sideburns gravatar imagesideburns ( 2016-05-11 19:53:59 -0500 )edit

answered 2016-05-12 13:03:49 -0500

jsmccloud gravatar image

Thank you for all of your help! After I installed Fedora 23, I was able to get the rpmfusion repository. I had to download the nonfree version for it to recognize the command below.

I then followed the RPMFusion Nvidia Guide checked which version card I had and then used the appropriate command to install the drivers.

/sbin/lspci | grep VGA

dnf install akmod-nvidia "kernel-devel-uname-r == $(uname -r)"
dnf update -y

After I rebooted, I haven't had it freeze on me since, so it appears the problem is fixed.

edit flag offensive delete link more

answered 2016-05-12 01:39:32 -0500

genodeftest gravatar image

Since there is no rpmfusion repo for Fedora 24 yet you'll have to stick with the open source nouveau driver for Nvidia cards. If you want proprietary drivers, you'll have to compile them yourself or go back to Fedora 23 where it still works.

edit flag offensive delete link more

answered 2017-01-28 16:04:33 -0500

EL_DON gravatar image

I had problems with Fedora 25 freezing on an MSI GP60 with an Nvidia GeForce GT 740M. I solved it by going in BIOS and changing PCI Latency Timer from 32 clocks to 64 clocks. I tried other things as well, like disabling speed step, but I've reverted everything but the latency timer change now.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-05-11 16:38:57 -0500

Seen: 3,938 times

Last updated: May 12 '16