Ask Your Question
0

terminal fedora 16

asked 2012-03-21 14:46:46 -0500

dom gravatar image

hello i type ( yum install gnome-tweak-tools ) in terminal command i have the following message.( you need to be root to perform this command ) please can someone tell me more about this message and next step to follow .THANKS DOM

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
2

answered 2012-03-21 14:53:26 -0500

Chetan Patil gravatar image

updated 2012-03-21 15:03:08 -0500

Hi,

Whenever you have to install packages using "yum" you need to be root. Here it saying that only root user can execute this command.

Try this : sudo yum install gnome-tweak-tools and terminal will prompt for your root password. Enter same and you are good to go.

If sudo doesn't work then try : su -c "yum install gnome-tweak-tools". As for sudo to work, that username has to be in sudoers file.

Warning : Don't play with "sudo" or root access until you understand it pretty well.

edit flag offensive delete link more
1

answered 2012-03-21 15:00:07 -0500

lanmaster82 gravatar image

sudo only works if your user is in the sudoers file.

you may have to try typing "su" in the terminal and entering the root password when it prompts for it. Then running yum.

But I agree, don't play with root access until you understand how much you can screw up.

edit flag offensive delete link more
1

answered 2012-03-22 14:39:48 -0500

Peter Scott gravatar image

updated 2012-03-22 14:40:13 -0500

As the others have said, you have to run yum as the root user. Here is an installation guide telling you about how to use su and sudo

edit flag offensive delete link more
1

answered 2012-03-22 08:01:17 -0500

Akshay gravatar image

you need to have root access to install packages

before you deal with yum i recommend you to go through this page

https://fedoraproject.org/wiki/Yum

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-03-21 14:46:46 -0500

Seen: 2,053 times

Last updated: Mar 22 '12