Ask Your Question
0

Mounting Iphone in Fedora

asked 2011-11-10 13:50:03 -0500

SoumyaC gravatar image

Whenever I try to mount Iphone (iOS 5) and Ipod Touch (iOS 5) in Fedora it gives me a

Unhandled Lockdown error (-4)

I have till date tried it only with F15 and F16. Any help ?

edit retag flag offensive close merge delete

Comments

for iOS files manager There are programs to do that. For example Iphone Music Manager link textIphone Music Manager

I used it few times.it's free and it works as good as can be expected. The main thing is to stop using the external hard disk until you use this tool, and avoid writing any files to it.

belly123 gravatar imagebelly123 ( 2017-01-05 00:41:20 -0500 )edit

5 Answers

Sort by » oldest newest most voted
1

answered 2011-11-10 15:23:20 -0500

Tom Tom gravatar image

Hi, I experienced the same problem mounting my iphone 4 (IOS 5) in fedora 16. It seems to come from the libimobiledevice package which is propably not compatible with IOS 5 yet.

I tried to build a source package of this library provided by another user on the bugzilla.redhat.com website. Here is the link : https://bugzilla.redhat.com/show_bug.cgi?id=750363">https://bugzilla.redhat.com/show_bug.cgi?id=750363.

It solved the problem, my Iphone can now be mounted in nautilus, rhythmbox and banshee.

But I dont really know if it's a safe way since it's not an official package..

edit flag offensive delete link more

Comments

Worked like a charm !! Thanks @Tom Tom

SoumyaC gravatar imageSoumyaC ( 2011-11-21 15:48:16 -0500 )edit
0

answered 2012-01-15 07:59:38 -0500

Works for me in FC16. My libimobiledevice is:

[root@tpx220 jonas]# rpm -qi libimobiledevice Name : libimobiledevice Version : 1.1.1 Release : 3.fc16 Architecture: x86_64 Install Date: fre 6 jan 2012 17.03.12 Group : System Environment/Libraries Size : 317610 License : LGPLv2+ Signature : RSA/SHA256, fre 2 dec 2011 16.47.14, Key ID 067f00b6a82ba4b7 Source RPM : libimobiledevice-1.1.1-3.fc16.src.rpm Build Date : tor 1 dec 2011 20.11.24 Build Host : x86-02.phx2.fedoraproject.org

My iPhone4 has version 5.0.1 (9A405), model MC605KS and Modemfirmware 04.11.08 .

I can use the iPhone as a "usb stick" to store files on it. It shows up in Rhythmbox and I can play music on the iPhone within Rhythmbox. And Shotwell can import my photos on the iPhone.

edit flag offensive delete link more
0

answered 2011-12-18 17:00:56 -0500

hhlp gravatar image

updated 2011-12-18 17:01:40 -0500

1.- you have to install this libraries :

su -c 'yum -y install gcc gtkpod libgpod ifuse gvfs-afc libiphone libusbmuxd usbmuxd libusb libusb-devel libmobiledevice libmobiledevice-devel libiphone-devel usbmuxd-devel'

2.- Optionally, if you want to manage your Apple device from Linux directly (support less complete) you must install a player that allows to them. in GNOME install Rhythmbox and in KDE install Amarok. It is also important to mention that with the installation of required packages installed gtkpod, a management program for Apple devices in your system. You can try to see how it works for you.

3.- Apply the patch in the previos post... while the patch pass from testing and become fixed... If you'd like you can install the updated package using the following command:

su -c 'yum --enablerepo=updates-testing libimobiledevice'
edit flag offensive delete link more
0

answered 2014-12-29 16:03:24 -0500

etm1109 gravatar image

I'm not having luck with my iPhone and Shotwelll. I keep getting messages like this:

Attempted to import 422 files. Of these, 0 files were successfully imported.

Photos/Videos Not Imported Due to Camera Errors:

IMG_0001.JPG error message: [-107] Error retrieving file object for /DCIM/874JSBTN/IMG_0001.JPG: Unknown error

IMG_0001.JPG error message: [-107] Error retrieving file object for /store_00010001/DCIM/907LDTDQ/IMG_0001.JPG: Unknown error

I've also noticed this happened after an update of Fedora a few months ago. Another interesting thing is my phone no longer pops up a message - Do you trust this connection?

edit flag offensive delete link more
0

answered 2012-03-23 19:52:20 -0500

imzax gravatar image

Ubuntu supports mounting of idevices right out of the box. Im using fedora now, I cant mount my ipad and access its filesystem. I wonder what nautilus-plugin should be used? or do i need to compile libimobiledevices myself?

edit flag offensive delete link more

Question Tools

Stats

Asked: 2011-11-10 13:50:03 -0500

Seen: 28,145 times

Last updated: Dec 29 '14