Ask Your Question
1

Problems with Yum

asked 2012-01-22 10:31:43 -0500

viajeramental gravatar image

updated 2012-10-06 00:17:48 -0500

mether gravatar image

Everytime I try to update I have this error message:

Error: Paquete: mencoder-1.0-0.128.20110816svn.fc16.i686 (rpmfusion-free-updates)
           Necesita: libx264.so.116
           Eliminando: x264-libs-0.0.0-0.31.20110811.fc16.i686 (@rpmfusion-free)
               libx264.so.116
           Obsoleto por: x264-0.118-17_20111111.2245.fc16.i686 (atrpms)
               No encontrado
 Podría intentar utilizar el comando --skip-broken para sortear el problema
Podría intentar ejecutar: rpm- Va --nofiles --nodigest

Somebody could tell me how can I fix it?

Thanks in advance!

edit retag flag offensive close merge delete

Comments

LC_ALL=C yum repolist

lzap gravatar imagelzap ( 2012-01-22 16:23:14 -0500 )edit

4 Answers

Sort by » oldest newest most voted
3

answered 2012-01-23 16:08:09 -0500

atrpms and rpmfusion are not compatible. They share many packages and have different versions.

I'd suggest disabling atrpms in /etc/yum.repos.d/atrpms* files, then doing a 'yum distro-sync' to sync back to the rpmfusion versions.

edit flag offensive delete link more

Comments

They are two different repositories of software, run by two different groups. They ship some of the same packages, but with different versions. If you have both enabled it leads to problems just like you are describing.

nirik gravatar imagenirik ( 2012-01-25 22:53:39 -0500 )edit
1

answered 2012-01-23 09:51:40 -0500

ZenDark gravatar image

updated 2012-01-23 09:52:24 -0500

You can try to remove the mencoder package until rpmfusion build the new version (if you are not using it):

yum remove mencoder

It will take a few hours or some days, until the new package get compiled and reach the mirrors...

edit flag offensive delete link more
1

answered 2012-01-23 11:10:26 -0500

yn1v gravatar image

You can exclude mencoder from the update

yum --exclude=mencoder update

or you can use what yum suggest

yum --skip-broken update

The first will be a work around for this issue. The second it is best because if the package becomes available, then it will be updated.

edit flag offensive delete link more
0

answered 2012-01-24 11:34:06 -0500

viajeramental gravatar image

I did it all but now it gaves this error message:

file /usr/lib/libopencore-amrwb.so.0.0.2 from install of opencore-amr-0.1.2-1.fc12.i686 conflicts with file from package libopencore-amrwb0-0.1.2-2.fc16.i686 file /usr/lib/libopencore-amrnb.so.0.0.2 from install of opencore-amr-0.1.2-1.fc12.i686 conflicts with file from package libopencore-amrnb0-0.1.2-2.fc16.i686 file /usr/lib/libva.so.1.3200.0 from install of libva-1.0.15-1.fc16.i686 conflicts with file from package libva1-1.0.15-7.fc16.i686 file /usr/lib/libva-x11.so.1.3200.0 from install of libva-1.0.15-1.fc16.i686 conflicts with file from package libva-x111-1.0.15-7.fc16.i686 file /usr/lib/libspandsp.so.2.0.0 from install of spandsp-0.0.6-0.5.pre18.fc16.i686 conflicts with file from package libspandsp2-1:0.0.6-17pre18.fc16.i686 file /usr/lib/libfaac.so.0.0.0 from install of faac-1.28-2.fc12.i686 conflicts with file from package libfaac0-1.28-6.fc16.i686

What can I do to fix it? Thanks in advance!

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-01-22 10:31:43 -0500

Seen: 1,730 times

Last updated: Feb 03 '12