Ask Your Question

not able to play any video players in fedora 23 ???

asked 2016-05-05 12:04:39 -0500

chinmaya gravatar image

i have tried with the default video player,vlc player, and many other i am new to linux not able to understand what is happening. i have tried installing gstremer plugins, rpm fusion (both free and non free).

can anyone help me with this.

edit retag flag offensive close merge delete


What formats are you trying to play, and have you tried gstreamer-plugins-bad* or gstreamer-plugins-ugly*.from RPMFusion?

wilf gravatar imagewilf ( 2016-05-05 12:49:00 -0500 )edit

yes i have tried gstreamer-plugins-bad and gstreamer-plugins-ugly and its not playing any format except the audio files

chinmaya gravatar imagechinmaya ( 2016-05-05 13:02:55 -0500 )edit

@chinmaya related question -> what-plugins-do-i-need

hhlp gravatar imagehhlp ( 2016-05-05 14:27:42 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2016-05-06 03:39:48 -0500

kvolny gravatar image

I understand that you'd probably appreciate some GUI solution, but just to verify the basic functionality, let's go to commandline ... please try the following:

  1. Install mplayer
  2. Run some terminal application (gnome-terminal, konsole, qterminal ...)
  3. Run mplayer "path/to/your/video.file"

If that works, you may just install smplayer as a graphical frontend and be happy with that. Or you may continue investigating why it doesn't work in other players.

Otherwise, if mplayer does not work, examine what error(s) does it report, and provide this information when seeking further help.

edit flag offensive delete link more


/usr/bin/mplayer: error while loading shared libraries: cannot open shared object file: No such file or directory

chinmaya gravatar imagechinmaya ( 2016-05-06 07:13:23 -0500 )edit

Well, that is strange - the library is in the a52dec package which should have been pulled in as a dependency of mplayer. So try to install a52dec too ... - just out of curiousity, how did you install mplayer, haven't you forced ignoring dependencies or is that a bug?

kvolny gravatar imagekvolny ( 2016-05-06 11:18:59 -0500 )edit

answered 2016-05-05 18:12:09 -0500

Phuti gravatar image

I had the same problem, Installing GStreamer Multimedia Codes solved the problem.

sudo dnf install gstreamer1-libav

edit flag offensive delete link more


did that too... not working

chinmaya gravatar imagechinmaya ( 2016-05-06 07:08:05 -0500 )edit

Question Tools



Asked: 2016-05-05 11:59:47 -0500

Seen: 374 times

Last updated: May 05 '16