Ask Your Question
0

Installing Fedora 23 x64 in Legacy Mode with Windows 10 (USB installation)

asked 2016-05-02 10:17:23 -0500

AlonzAzo gravatar image

I was trying to install Fedora 23 x64 with Windows 10 x64. My computer doesn't support UEFI mode, just legacy. My problem is when I plug the usb in BIOS just identify an UEFI USB. If I boot it from it, there's a moment that a message like this appears:

"For a UEFI installation, you must include an EFI System Partition on a GPT-formatted disk, mounted at /boot/efi"

In BIOS I activated the legacy USB support, but still just USB UEFI is identified.

How can I do to my computer identify the USB in legacy mode? I've tried to delete .EFI in /EFI/BOOT/ folder, but it still continues happening.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-05 18:59:44 -0500

Phuti gravatar image

I had the same problem, my laptop was still new so I didn't have any important files on my drive and default mode was legacy. I formatted the whole drive and re-installed Windows, and automatically installed in UEFI mode. If you have important files on your drive, create a backup, because this method will erase all of your data.

  1. Insert Windows installer disc, when the installer prompt for windows activation key, press left shift + F10, CMD will open.

  2. type diskpart.

  3. type list disk, this will list all disks on the drive, including Disk 0, you may have more disks.

  4. type select Disk 0, or select the disk you want to install windows on, mine was Disk 0.

  5. type clean, this might take a bit of time.

  6. Now convert the drive to GPT, type convert GPT. close CMD and continue to install windows, after that you will be able to install fedora.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-05-02 10:17:23 -0500

Seen: 1,729 times

Last updated: May 05 '16