Ask Your Question
0

no valid boot loader target found

asked 2016-05-01 20:04:04 -0500

Phuti gravatar image

I have been trying to install fedora on my laptop in a dual boot, running windows 8.1, BIOS is in a legacy mode, for the past 24 - 36 hours and I don't know what to do anymore. Anaconda doesn't want to automatically partition my drive. I'm doing it manually. I get this error message "No valid boot loader target device found. See below for details. For a UEFI installation, you must include an EFI System Partition on a GPT-formatted disk, mounted at /boot/efi."

Screenshot : http://postimg.org/image/glpvdc7xd/

edit retag flag offensive close merge delete

Comments

Since there seems the be another OS on that drive, you certainly should not reformat the EFI boot partition, which is used by all the OSes on that disk. Furthermore, there must be only one EFI boot partition on the disk.

jmt gravatar imagejmt ( 2016-05-02 10:19:22 -0500 )edit

Both, Fedora 23 and Windows 8.1 work in UEFI mode (non-legacy mode), why do you enable legacy mode then?

genodeftest gravatar imagegenodeftest ( 2016-05-02 11:03:22 -0500 )edit

My laptop came with 32 bit windows 8.1 pre-installed, with legacy mode enabled. I have formatted the drive using windows DiskPart and re-installed windows 8.1 x64 in UEFI mode, and my problem was solved.

Phuti gravatar imagePhuti ( 2016-05-05 06:19:57 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-05-05 19:04:45 -0500

Phuti gravatar image

I have solved this problem by, formatting my drive and re-installing windows. My laptop was still new I didn't have any important files on my drive. Using DiskPart I converted the drive to GPT.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-05-01 20:04:04 -0500

Seen: 2,706 times

Last updated: May 05 '16