Ask Your Question
0

I can not start TeamViewer after installation. (F24 alpha)

asked 2016-04-28 04:36:25 -0500

Sane76 gravatar image

updated 2016-04-28 09:50:51 -0500

I can not start TeamViewer after installation. (F24 alpha)

[username@localhost ~]$ su -
Пароль: 
[root@localhost ~]# teamviewer

Init...
XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
Network process started (5939)
Launching TeamViewer GUI ...
[root@localhost ~]#

TeamViewer error "TeamViewer did not start". Need comand "teamviewer --daemon start"

[root@localhost ~]# teamviewer --daemon start

systemctl start teamviewerd.service
Job for teamviewerd.service failed because a fatal signal was delivered to the control process. See "systemctl status teamviewerd.service" and "journalctl -xe" for details.
fail

[root@localhost ~]#
edit retag flag offensive close merge delete

Comments

what is output for "sudo systemctl status teamviewerd.service" command and for the "sudo journalctl -xe -u teamviewerd.service" ?

mrTuborg gravatar imagemrTuborg ( 2016-04-28 05:31:58 -0500 )edit

Hi all! Same issue here, after the upgrade to Fedora 24 I'm facing the same problem, any news regarding this? Thanks in advance!

Julian G. gravatar imageJulian G. ( 2016-06-26 10:53:40 -0500 )edit

9 Answers

Sort by » oldest newest most voted
2

answered 2016-06-20 13:30:53 -0500

Denis Butov gravatar image

sudo ausearch -c 'teamviewerd' --raw | audit2allow -M my-teamviewerd

sudo semodule -X 300 -i my-teamviewerd.pp

SELinux is preventing teamviewerd from using the execmem access on a process.

                                     *****  Plugin catchall (100. confidence) suggests   **************************

                                     If you believe that teamviewerd should be allowed execmem access on processes labeled init_t by default.
                                     Then you should report this as a bug.
                                     You can generate a local policy module to allow this access.
                                     Do
                                     allow this access for now by executing:
                                     # ausearch -c 'teamviewerd' --raw | audit2allow -M my-teamviewerd
                                     # semodule -X 300 -i my-teamviewerd.pp
edit flag offensive delete link more

Comments

In for the fix! I tried everything above to no avail as well, and am opening a case with Teamviewer this AM, will post what they have me do to fix. Edited to add: This happened to me with the final release of Fedora 24 yesterday, 6/21. Opened a ticket with Teamviewer and waiting for a response.

One more edit: Confirmed that TV is also broken on a fresh install of 24 in a VM, with the exact same error messages.

zenzer gravatar imagezenzer ( 2016-06-22 09:01:01 -0500 )edit

Ok, I haven't heard back from Teamviewer yet, and I didn't do anything, but when I got home and I turned my laptop on I launched Teamviewer to again go over the errors and see what I can find, and it worked. Didn't do anything but reboot, but I tried that earlier. Restarted and opened again and it still works. Go figure.

zenzer gravatar imagezenzer ( 2016-06-22 21:25:37 -0500 )edit

Works for me after generating this policy module. Thanks.

bronzebeard gravatar imagebronzebeard ( 2016-06-23 01:29:46 -0500 )edit

Well, it still wouldn't run in my VM even after updating Fedora a couple times, so I kept the support case open with Teamviewer active even after my laptop was working fine. They sent the below email, and the instructions worked. Now I swear I tried that already, based on a post here, and it didn't work. But, here is what they sent if anyone still needs this info.

If the result is enforced, please run the following commands to allow TeamViewer to be executed.

ausearch -c 'teamviewerd' --raw | audit2allow -M my-teamviewerd

semodule -X 300 -i my-teamviewerd.pp

zenzer gravatar imagezenzer ( 2016-06-28 15:00:01 -0500 )edit

Denis Butov's solution above worked for me, thanks!

vv132 gravatar imagevv132 ( 2016-09-22 02:31:47 -0500 )edit
0

answered 2016-08-11 13:06:51 -0500

pbrevig gravatar image

Hi folks.

After struggling with the daemon issue and SELinux alerts like many of you, I SUCCESSFULLY deployed TeamViewer 11 on Fedora 24 with a slightly different sequence of commands than the suggested ones. Feel free to try and share your results.

Download and install the TeamViewer .rpm package with dnf, and then execute the following commands (always as sudo):

sudo ausearch -c 'teamviewerd' --raw | audit2allow -M my-teamviewerd

sudo semodule -i my-teamviewerd.pp

sudo teamviewer daemon stop

sudo teamviewer daemon start

sudo teamviewer daemon enable

sudo systemctl enable teamviewerd.service

sudo systemctl start teamviewerd.service

TeamViewer 11 is fully operational in my machine! Good luck!

edit flag offensive delete link more

Comments

Hi,

sudo semodule -i my-teamviewerd.pp

returns this error

Re-declaration of boolean virt_sandbox_use_fusefs
Failed to create node
Bad boolean declaration at /var/lib/selinux/targeted/tmp/modules/100/virt/cil:148
semodule:  Failed!
Babarinde gravatar imageBabarinde ( 2016-08-17 06:38:37 -0500 )edit

Interesting. In my case I was instructed to run "sudo semodule -i my-teamviewerd.pp" in response to the previous command ("sudo ausearch -c 'teamviewerd' --raw | audit2allow -M my-teamviewerd"). All went well in my case. My knowledge is limited, so I'm afraid I can't help much beyond this...

pbrevig gravatar imagepbrevig ( 2016-08-17 12:26:48 -0500 )edit

Hi, Worked fine. Thanks for the help.

Mahim gravatar imageMahim ( 2016-10-14 06:30:22 -0500 )edit
0

answered 2016-04-28 07:40:56 -0500

Sane76 gravatar image

updated 2016-04-28 09:55:03 -0500

[root@localhost ~]# sudo systemctl status teamviewerd.service
● teamviewerd.service - TeamViewer remote control daemon
   Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor pres
   Active: inactive (dead) (Result: signal) since Чт 2016-04-28 17:33:13 MSK; 18

апр 28 17:33:12 localhost.localdomain systemd[1]: teamviewerd.service: Unit ente
апр 28 17:33:12 localhost.localdomain systemd[1]: teamviewerd.service: Failed wi
апр 28 17:33:13 localhost.localdomain systemd[1]: teamviewerd.service: Service h
апр 28 17:33:13 localhost.localdomain systemd[1]: Stopped TeamViewer remote cont
апр 28 17:33:13 localhost.localdomain systemd[1]: teamviewerd.service: Start req
апр 28 17:33:13 localhost.localdomain systemd[1]: Failed to start TeamViewer rem
lines 1-10/10 (END)...skipping...
● teamviewerd.service - TeamViewer remote control daemon
   Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: disabled)
   Active: inactive (dead) (Result: signal) since Чт 2016-04-28 17:33:13 MSK; 18min ago

апр 28 17:33:12 localhost.localdomain systemd[1]: teamviewerd.service: Unit entered failed state.
апр 28 17:33:12 localhost.localdomain systemd[1]: teamviewerd.service: Failed with result 'signal'.
апр 28 17:33:13 localhost.localdomain systemd[1]: teamviewerd.service: Service hold-off time over, scheduling restart.
апр 28 17:33:13 localhost.localdomain systemd[1]: Stopped TeamViewer remote control daemon.
апр 28 17:33:13 localhost.localdomain systemd[1]: teamviewerd.service: Start request repeated too quickly.
апр 28 17:33:13 localhost.localdomain systemd[1]: Failed to start TeamViewer remote control daemon.
~
[root@localhost ~]#

and

[root@localhost ~]# sudo journalctl -xe -u teamviewerd.service
апр 28 17:33:12 localhost.localdomain systemd[1]: Failed to start TeamViewer remote control daemon.
-- Subject: Ошибка юнита teamviewerd.service
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Произошел сбой юнита teamviewerd.service.
-- 
-- Результат: failed.
апр 28 17:33:12 localhost.localdomain systemd[1]: teamviewerd.service: Unit entered failed state.
апр 28 17:33:12 localhost.localdomain systemd[1]: teamviewerd.service: Failed with result 'signal'.
апр 28 17:33:12 localhost.localdomain systemd[1]: teamviewerd.service: Service hold-off time over, scheduling restart.
апр 28 17:33:12 localhost.localdomain systemd[1]: Stopped TeamViewer remote control daemon.
-- Subject: Завершена остановка юнита teamviewerd.service.
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Процесс остановки юнита teamviewerd.service был завершен.
апр 28 17:33:12 localhost.localdomain systemd[1]: Starting TeamViewer remote control daemon...
-- Subject: Начинается запуск юнита teamviewerd.service
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Начат процесс запуска юнита teamviewerd.service.
апр 28 17:33:12 localhost.localdomain systemd[1]: teamviewerd.service: Control process exited, code=killed status=11
апр 28 17:33:12 localhost.localdomain systemd[1]: Failed to start TeamViewer remote control daemon.
-- Subject: Ошибка юнита teamviewerd.service
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Произошел сбой юнита teamviewerd.service.
-- 
-- Результат: failed.
апр 28 17:33:12 localhost.localdomain systemd[1]: teamviewerd.service: Unit entered failed state.
апр 28 17:33:12 localhost.localdomain systemd[1]: teamviewerd.service: Failed with result 'signal'.
апр ...
(more)
edit flag offensive delete link more

Comments

1

Hi, this isn't an answer. Can you please edit your question to put this info there instead?

randomuser gravatar imagerandomuser ( 2016-06-26 12:47:58 -0500 )edit
0

answered 2016-08-02 14:07:14 -0500

NibidAlo gravatar image

I've solved this issue by following:

$ systemctl status teamviewerd.service

$ teamviewer --daemon start

$ ausearch -c 'teamviewerd' --raw | audit2allow -M my-teamviewerd

$ semodule -i my-teamviewerd.pp

$ teamviewer --daemon start

and now open your TeamViewer

edit flag offensive delete link more
0

answered 2016-06-27 12:04:32 -0500

updated 2016-06-27 12:07:32 -0500

In my case by deactivating SElinux, and running the #teamviewr --daemon start and than #teamview, it worked fine. After that even through other means without been root, it also worked fine. So in last case you can try to deactivate SElinux.

edit flag offensive delete link more
0

answered 2016-07-18 06:39:19 -0500

PPK gravatar image

Hai !

I found the solution here. All credits go to that author.

I am reproducing it here for easy reference ...

To add an SELinux policy to allow TeamViewer ...

ausearch -c 'teamviewerd' --raw | audit2allow -M my-teamviewerd
semodule -X 300 -i my-teamviewerd.pp

You can then start TeamViewer daemon by ...

systemctl start teamviewerd.service

To remove the above policy ...

semodule -l | grep team
semodule -X 300 -r my-teamviewerd
edit flag offensive delete link more
0

answered 2016-06-19 03:05:17 -0500

diman82 gravatar image

updated 2016-06-20 14:22:46 -0500

hhlp gravatar image

I'm facing the very same issue over here:

[diman82@diman82-laptop ~]$ teamviewer --daemon start
systemctl start teamviewerd.service
Job for teamviewerd.service failed because a fatal signal was delivered to the control process. See "systemctl status teamviewerd.service" and "journalctl -xe" for details.
fail

Try with root / sudo ?

[diman82@diman82-laptop ~]$ systemctl status teamviewerd.service
● teamviewerd.service - TeamViewer remote control daemon
   Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: disabled)
   Active: inactive (dead) (Result: signal) since Sun 2016-06-19 10:51:00 IDT; 5s ago
  Process: 5127 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=killed, signal=SEGV)

Jun 19 10:51:00 diman82-laptop systemd[1]: Failed to start TeamViewer remote control daemon.
Jun 19 10:51:00 diman82-laptop systemd[1]: teamviewerd.service: Unit entered failed state.
Jun 19 10:51:00 diman82-laptop systemd[1]: teamviewerd.service: Failed with result 'signal'.
Jun 19 10:51:00 diman82-laptop systemd[1]: teamviewerd.service: Service hold-off time over, scheduling restart.
Jun 19 10:51:00 diman82-laptop systemd[1]: Stopped TeamViewer remote control daemon.
Jun 19 10:51:00 diman82-laptop systemd[1]: teamviewerd.service: Start request repeated too quickly.
Jun 19 10:51:00 diman82-laptop systemd[1]: Failed to start TeamViewer remote control daemon.

I've submitted a ticket to TeamViewer support team, will update after the issue is resolved.

edit flag offensive delete link more
0

answered 2016-09-14 09:28:53 -0500

updated 2016-09-14 10:14:35 -0500

hhlp gravatar image

maybe, this may help

# systemctl start teamviewerd.service

# systemctl status teamviewerd.service 
● teamviewerd.service - TeamViewer remote control daemon
   Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: disabled)

   Active: **active (running)** since Wed 2016-09-14 21:20:45 WIB; 1s ago
  Process: 30081 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
 Main PID: 30084 (teamviewerd)
    Tasks: 15 (limit: 512)
   CGroup: /system.slice/teamviewerd.service
           └─30084 /opt/teamviewer/tv_bin/teamviewerd -d

Sep 14 21:20:45 nusa systemd[1]: Starting TeamViewer remote control daemon...
Sep 14 21:20:45 nusa systemd[1]: Started TeamViewer remote control daemon.
edit flag offensive delete link more
0

answered 2017-01-27 10:09:14 -0500

Hello everyone, I could not make it work.

The service is OK

● teamviewerd.service - TeamViewer remote control daemon
Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: disabled)
Active: active (running) since vie 2017-01-27 12:28:37 UYT; 23min ago
Main PID: 8469 (teamviewerd)
Tasks: 14 (limit: 4915)
CGroup: /system.slice/teamviewerd.service
           └─8469 /opt/teamviewer/tv_bin/teamviewerd -d

But when I execute the command: ausearch -c 'teamviewerd', return:

<no matches>

Thank You. Any help is appreciated

edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-04-28 04:36:25 -0500

Seen: 15,614 times

Last updated: Sep 14 '16