Mount via cifs doesn't work anymore (Samba)

asked 2016-04-21 18:41:07 -0500

Hadden gravatar image

updated 2016-04-23 08:21:59 -0500

My home network is not seen by file managers (is not fedora specific issue, it's happening also on other distros) so I can't simply use the built-in network function to access my shares (which are on windows 7 server)

I found a simply mode to access/mount them and it worked, but strangely it stopped to.

mount -t cifs //192.168.1.101/<sharename>/ /home/hadden/Condivisioni/<sharename>

(After this, the terminal prompt me to insert user/password server to access)

Probably I fixed, don't sure if this command helped (Probably don't, but it's useful; I also reset all server firewall settings to solve the issue)

smbclient //<serverip>/<sharename> -U <username>

and then

mount -t cifs //192.168.1.101/Musica /home/hadden/Condivisioni/Musica
Password for hadden@//192.168.1.101/Musica:  ******

Shares again! and then

mount -a

that should keep them permanent (if not I put in etc/fstab) The command I put above, saying

mount

is seen as

//192.168.1.101/Musica on /home/hadden/Condivisioni/Musica type cifs  (rw,relatime,vers=1.0,cache=strict,username=hadden,domain=HADDEN-PC,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.1.101,file_mode=0755,dir_mode=0755,nounix,serverino,mapposix,rsize=61440,wsize=65536,actimeo=1)

and seems pretty working and more complete, even if neither direct smb://<server>/<share> or network:///<server>//<share> from file manager seems to work (but this system seems to be more faster and reliable: this folder, for example, didn't work at all with that system) but works from this very useful share cifs system.

edit retag flag offensive close merge delete

Comments

The most important information put in parenthesis? Looks more like a server configuration issue than a client-side problem...

florian gravatar imageflorian ( 2016-04-21 23:30:17 -0500 )edit

I woudl look into share configuration on your Windows 7 box. Especially that I don't see any user information in your command.

pbogu gravatar imagepbogu ( 2016-04-22 03:06:49 -0500 )edit

I don't think is a server configuration error as I have not changed anything in it. I used this string to access (terminal prompt for user/password server) my shares and it worked. The command smbclient, for example, sees correctly windows server.and enters in it All shares in server are set to "everyone" (which should be authenticated ones). If you have any ideas to improve command, or try other better ways, I'll do.

Hadden gravatar imageHadden ( 2016-04-22 05:42:16 -0500 )edit

Did you check mount -v (--verbose) to check for any errors/messages from mount itself?

pbogu gravatar imagepbogu ( 2016-04-22 05:56:43 -0500 )edit

No I'll remember this command, but I haven't any samba share there, however, for now is working again. The error given during mount was something about parse (sorry I don't remember exactly)

Hadden gravatar imageHadden ( 2016-04-22 08:25:43 -0500 )edit