Ask Your Question
1

pygobject make error

asked 2012-07-03 09:01:57 -0600

mjnovice gravatar image

i am using fedora 17 and was trying to install pygobject 2.x and it configured flawlessy but while making it crashed following is the log

make  all-recursive
make[1]: Entering directory `/home/mayank/Desktop/pygobject-2.26.0'
Making all in docs
make[2]: Entering directory `/home/mayank/Desktop/pygobject-2.26.0/docs'
make  all-am
make[3]: Entering directory `/home/mayank/Desktop/pygobject-2.26.0/docs'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/mayank/Desktop/pygobject-2.26.0/docs'
make[2]: Leaving directory `/home/mayank/Desktop/pygobject-2.26.0/docs'
Making all in codegen
make[2]: Entering directory `/home/mayank/Desktop/pygobject-2.26.0/codegen'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/mayank/Desktop/pygobject-2.26.0/codegen'
Making all in glib
make[2]: Entering directory `/home/mayank/Desktop/pygobject-2.26.0/glib'
ln -s .libs/_glib.so _glib.so || true
ln: failed to create symbolic link `_glib.so': File exists
make[2]: Leaving directory `/home/mayank/Desktop/pygobject-2.26.0/glib'
Making all in gobject
make[2]: Entering directory `/home/mayank/Desktop/pygobject-2.26.0/gobject'
ln -s .libs/_gobject.so _gobject.so || true
ln: failed to create symbolic link `_gobject.so': File exists
make[2]: Leaving directory `/home/mayank/Desktop/pygobject-2.26.0/gobject'
Making all in gio
make[2]: Entering directory `/home/mayank/Desktop/pygobject-2.26.0/gio'
ln -s .libs/_gio.so _gio.so || true
ln: failed to create symbolic link `_gio.so': File exists
ln -s .libs/unix.so unix.so || true
ln: failed to create symbolic link `unix.so': File exists
make[2]: Leaving directory `/home/mayank/Desktop/pygobject-2.26.0/gio'
Making all in examples
make[2]: Entering directory `/home/mayank/Desktop/pygobject-2.26.0/examples'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/mayank/Desktop/pygobject-2.26.0/examples'
Making all in gi
make[2]: Entering directory `/home/mayank/Desktop/pygobject-2.26.0/gi'
Making all in repository
make[3]: Entering directory `/home/mayank/Desktop/pygobject-2.26.0/gi/repository'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/mayank/Desktop/pygobject-2.26.0/gi/repository'
Making all in overrides
make[3]: Entering directory `/home/mayank/Desktop/pygobject-2.26.0/gi/overrides'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/mayank/Desktop/pygobject-2.26.0/gi/overrides'
make[3]: Entering directory `/home/mayank/Desktop/pygobject-2.26.0/gi'
  CC     _gi_la-pygi-info.lo
pygi-info.c: In function ‘_pygi_info_new’:
pygi-info.c:137:14: error: ‘GI_INFO_TYPE_ERROR_DOMAIN’ undeclared (first use in this function)
pygi-info.c:137:14: note: each undeclared identifier is reported only once for each function it appears in
pygi-info.c:107:5: warning: enumeration value ‘GI_INFO_TYPE_INVALID_0’ not handled in switch [-Wswitch]
pygi-info.c: In function ‘_pygi_g_type_tag_size’:
pygi-info.c:246:5: warning: enumeration value ‘GI_TYPE_TAG_UNICHAR’ not handled in switch [-Wswitch]
pygi-info.c: In function ‘_pygi_g_type_info_size’:
pygi-info.c:365:22: error: ‘GI_INFO_TYPE_ERROR_DOMAIN’ undeclared (first use in this function)
pygi-info.c ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2012-10-08 13:24:42 -0600

dmalcolm gravatar image

It looks like you've got a mismatch between gobject-introspection and pygobject.

The relevant enum values GI_INFO_TYPE_ERROR_DOMAIN etc that were in gobject-introspection were removed in http://git.gnome.org/browse/gobject-introspection/commit/?id=e9f0e44f27e8c16174b2da8aee2a2f2cd06c8418 but the version of pygobject you're building still uses them, hence the compilation errors.

The changelog for pygobject 2.90.1 at https://mail.gnome.org/archives/ftp-release-list/2011-August/msg00026.html includes:

    - remove references to deprecated GI_INFO_TYPE_ERROR_DOMAIN (John (J5) Palmieri)

so if you're still attempting this, it looks like you'll want that version or later.

Hope this is helpful

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-07-03 09:01:57 -0600

Seen: 1,619 times

Last updated: Oct 08 '12