Ask Your Question
0

error: Failed build dependencies:

asked 2012-11-05 00:17:58 -0500

juned gravatar image

Hi All, I am trying to build the .rpm package. i have just followed the steps to do that. Till now all step was gone fine but now i just stuck with this step. I just ran the following command and got this error :

rpmbuild -ba asterisk.spec
error: Failed build dependencies: 
    gtk2-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libsrtp-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    gmime22-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    graphviz is needed by asterisk-1.8.12.2-1.fc15.x86_64
    graphviz-gd is needed by asterisk-1.8.12.2-1.fc15.x86_64
    latex2html is needed by asterisk-1.8.12.2-1.fc15.x86_64
    neon-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libical-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    speex-devel >= 1.2 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    gsm-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libedit-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    openais-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    alsa-lib-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    dahdi-tools-devel >= 2.0.0 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    dahdi-tools-libs >= 2.0.0 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libpri-devel >= 1.4.12 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libss7-devel >= 1.0.1 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    spandsp-devel >= 0.0.5-0.1.pre4 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    iksemel-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    jack-audio-connection-kit-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libresample-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    lua-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    mISDN-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    bluez-libs-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libtool-ltdl-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    unixODBC-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    portaudio-devel >= 19 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    postgresql-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    radiusclient-ng-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    net-snmp-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    lm_sensors-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    freetds-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    uw-imap-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64

I am using fedora-15. How to resolve this error? Any idea and suggestion will be appreciated
Thanks

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2012-11-05 02:08:22 -0500

kubo gravatar image

These packages are necessary to build your package - you can find them as BuildRequires in your spec file. You need to have them all installed on your build system. Or you can use mock to build packages - it will install these packages automaticly to its environment (chroot).

edit flag offensive delete link more
3

answered 2012-11-05 07:44:20 -0500

Remi gravatar image

yum-builddep is your friend.

Try

yum-buildep /patch/to/foo.spec

Or

yum-buildep /path/to/foo.src.rpm

This command is provided by the yum-utils package.

edit flag offensive delete link more
0

answered 2012-11-11 15:17:31 -0500

updated 2012-12-14 01:09:58 -0500

Fedora is a packaged distribution. While it is possible to compile everything from source and maintain products and their dependencies yourself, you deny yourself of the benefits of the Fedora community. There are already people doing the work of preparing asterisk for Fedora.

You can easily get a list of asterisk related packages:

yum search asterisk

I understand that there are use cases that require building the package yourself, but I think it is important to make the point for the benefit of users that don't fully understand the context of the issue.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2012-11-05 00:17:58 -0500

Seen: 5,082 times

Last updated: Dec 14 '12