Ask Your Question
0

Fedora 18 where is "allow different layouts for individual windows" settings?

asked 2012-12-03 08:52:34 -0500

MarkDevil gravatar image

Hi all, I remember that in older Fedora and Gnome releases there was an option that allows me to have different keyboard layouts for different windows. So, I tried to configure the keyboard but I have not found the option both in Keyboard and in Region settings. I'm using Fedora 18 and Gnome shell 3.6.2.. Can you help me?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2013-02-06 16:03:36 -0500

ryanlerch gravatar image

updated 2013-02-10 19:45:27 -0500

Between GNOME 3.4 (Fedora 17) and GNOME 3.6 (Fedora 18) the input methods code was completely rewritten. Sadly The ability to allow different layouts for individual windows did not get re-implemented in time for Fedora 18.

The good news is that according to mclasen (a GNOME developer), this feature will be added back for GNOME 3.8.

The bad news? GNOME 3.8 will only be in Fedora 19.

However, there also looks like there is an extension available in the GNOME extension library that re-enables this behaviour. Hopefully it works well enough to tide you over until F19 comes out. https://extensions.gnome.org/extension/596/per-window-keyboard-layout/

If you are interested in how this feature will look in GNOME 3.8, the following gnome bug has some mockups of it: https://bugzilla.gnome.org/show_bug.cgi?id=692672

edit flag offensive delete link more

Comments

@prahlad, would you be able to ask a new question about the firewall? that will probably be good to have in a seperate question :)

ryanlerch gravatar imageryanlerch ( 2013-02-10 19:48:38 -0500 )edit
0

answered 2012-12-03 09:45:57 -0500

davidva gravatar image

Hi, try it:

su 

yum -y install system-config-language

system-config-language
edit flag offensive delete link more
0

answered 2013-02-09 15:37:31 -0500

Bobas gravatar image

There is an extension exactly for solving this problem. https://extensions.gnome.org/extension/596/per-window-keyboard-layout/

edit flag offensive delete link more
0

answered 2013-02-06 15:32:29 -0500

prahlad gravatar image

@MarkDevil - I just installed Fedora 18 on my notebook, and faced the exact same issue. The option button is missing in the keyboard and region settings. Have you had any luck yet ?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-12-03 08:52:34 -0500

Seen: 2,581 times

Last updated: Feb 10 '13