Ask Your Question
2

Switching to init 3 removes wifi device Fedora 23

asked 2016-04-09 14:23:27 -0500

Woland gravatar image

So I've happily ditched Gnome in favor of StumpWM, unfortunately, after an update, I am unable to start Stump from GDM: I have to get into a terminal, do init 3, then startx like in the old days. This used to work until an update: now when I switch runlevels, my wifi is gone from NetworkManager.

lspci | grep Net shows that the card is present.

iwconfig shows the device but no active link.

nmcli c show shows the connection, but there is a -- under "DEVICE":

 nmcli c show
NAME         UUID                                  TYPE             DEVICE     
virbr2       8f33f980-43ab-40c1-a948-6cfee1f2a542  bridge           virbr2
enp4s0       995cdb05-ddc1-4e52-a217-cdb9641072c5  802-3-ethernet   --         
MySSID       1f9c5fd9-b29c-d743-2be0-6fb11ae99e8c  802-11-wireless  --     
wifi-wlp3s6  f5ffb6ca-cedd-41e0-a875-dbfc77bcc9c0  802-11-wireless  --

and I can't bring my connection up. How can I connect the WiFi after changing to init 3?

edit retag flag offensive close merge delete

Comments

1

So I think the problem is with some Gnome-SELinux policy changes, but at this point it's easier for me to try something like this and at least see if it works. --It sort of works, generates some errors but works. You also have to run dhcp client afterwards. If there isn't a better answer to this question, I'll clean this up and make it an answer.

Woland gravatar imageWoland ( 2016-04-10 13:16:23 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2016-04-11 16:40:28 -0500

genodeftest gravatar image

Why don't you systemctl disable gdm? Probably systemd's alias for runlevel 3 is not including the network target. Can you check that please?

edit flag offensive delete link more

Comments

"Why don't you systemctl disable gdm" --- because I didn't think it would be that easy. Thanks!

" systemd's alias for runlevel 3 is not including the network target." ---- They're all off!

/sbin/chkconfig --list | grep etw
network         0:off   1:off   2:off   3:off   4:off   5:off   6:off

What I didn't expect is that this would change after an update. Is this Fedora's not-so-subtle way of weaning us off init levels? Disabling gdm fixed my problems, so my init 5 is now what init 3 should be.

Woland gravatar imageWoland ( 2016-04-13 14:26:21 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2016-04-09 14:23:27 -0500

Seen: 298 times

Last updated: Apr 11 '16