Ask Your Question
1

Volume controls on keyboard stopped working

asked 2016-04-07 14:21:08 -0500

layertwo gravatar image

Hi

I have a Microsoft keyboard and the extra controls on my keyboard stopped working. (Volume, calculator, mute)

They used to work.. Is there a way to restoire these controls?

Many thanks in advance,

edit retag flag offensive close merge delete

Comments

stop working after what ? , upgrade F22 to F23 , update kernel ? install steam ? after a normal update ? etc .

sergiomb gravatar imagesergiomb ( 2016-04-07 16:09:04 -0500 )edit

Hi To be honest I dont know. After I install Fedora, I usually run updates, install Steam etc.. the usual stuff so anything might have broken it.

layertwo gravatar imagelayertwo ( 2016-04-08 13:13:13 -0500 )edit

It appears this https://bugzilla.rpmfusion.org/show_b... report today looks like have some similarities

sergiomb gravatar imagesergiomb ( 2016-04-08 17:45:52 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-04-08 08:20:41 -0500

snowolfe gravatar image

Do you have multiple sound output devices; e.g., Internal speakers and external speakers. I find my keyboard multimedia keys (volume in particular) don't appear to work if the wrong sound output device is currently selected. Once I switch to the correct output device, they work again. Usually I am trying to adjust my external speakers, but the keys are being sent to the internal device - even though the sound is coming out via the external speakers.

I use the Gnome Shell extension - Volume Mixer, to switch devices via the top right settings menu (assuming you are using Gnome Shell).

edit flag offensive delete link more

Comments

Thanks. Tried that but it didnt make any difference.

layertwo gravatar imagelayertwo ( 2016-04-08 13:13:59 -0500 )edit
1

answered 2016-04-07 15:45:35 -0500

genodeftest gravatar image
  1. Are you using Gnome? If yes, open gnome-control-center and have a look at the "Keyboard" page. Are these buttons registered for sound? You might reset them using dconf-editor with the schema org.gnome.settings-daemon.plugins.media-keys

  2. Does your media player support gnome multimedia keys?

  3. does your hardware work? You might want to have a look at xinput list, and then try xinput test-xi2 ID for every keyboard device ID listed before. Or just boot into another system (Fedora Live or Windows if you have multiboot) and make sure the buttons still work. Sometimes the hardware is the issue.

edit flag offensive delete link more

Comments

Button are registered and hardware is wording fine.

layertwo gravatar imagelayertwo ( 2016-04-08 13:13:38 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-04-07 14:21:08 -0500

Seen: 2,919 times

Last updated: Apr 08 '16