How to force nitrogen over gsettings to handle desktop wallpaper

asked 2016-04-06 23:21:33 -0500

happymonkey gravatar image

Hi, I recently switched from Windows to fedora 23 and it was one of the best decisions I have ever made.

I am currently trying to get Nitrogen working, so that my Multi-Monitor Setup can have different wallpapers on different monitors. I'm using fedora with GNOME 3.

The problem: Simply if I try to set a wallpaper with nitrogen nothing happens. Nothing. Nitrogen says the picture is currently set, and strangely when i restart my system, the wallpaper set by GNOME flashes and I can see the wallpapers set by nitrogen for (.5 sec) before the system reboots. My terminal also does not show me any errors.

The cause: I am pretty sure GNOME (gsettings) simply "overwrites" the wallpaper set by Nitrogen.

What I have already tried to do: In various posts I read, they say that I have to disable that the file manager that handles the desktop in the GNOME Tweak Tool. Sadly my version of the Tweak Tool does not have this option under "Desktop" anymore.

I found a poster, which had a similar issue, he could not find this setting in the Tweak Tool. He was recommended that he change this setting with the dconf-editor under org.gnome.desktop.background. The poster answered he could not find some setting to change with the dconf-editor, nor do I.

Has anyone experienced similar problems, and know how to fix this?

Thank you!

edit retag flag offensive close merge delete