Ask Your Question

How to run Gnome3 shell in Virtualbox on fedora 16 ?

asked 2011-12-07 03:14:47 -0500

Deena gravatar image

updated 2011-12-07 06:31:34 -0500

SoumyaC gravatar image


For me GNOME3 not working inside virtual box. Please help.

  1. Fedora Version 16
  2. Virtual Box Version 4.1.6
  3. Have 1 GB graphics card
  4. Enabled 3D Acceleration in Setting.
  5. Installed Guest Additions.
  6. Changed SELINUX=disabled from enforcing in /etc/selinux/config file.

Regards, Deena

edit retag flag offensive close merge delete


hhlp gravatar imagehhlp ( 2011-12-07 05:41:22 -0500 )edit

Go for gnome-shell --replace

SoumyaC gravatar imageSoumyaC ( 2011-12-07 07:09:41 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2011-12-07 03:36:17 -0500

Stanislav Ochotnicky gravatar image

Gnome 3 in Fedora 16 requires a lot from hardware acceleration and I believe VirtualBox might not provide everything needed fro Gnome 3 to work correctly. Gnome 3 in Fedora 17 will have this problem fixed by enabling software acceleration.

Until that time it is probably best to avoid virtualized Gnome 3. You can try out some of the other environments Fedora provides. Who knows, you might even like them! :-D

edit flag offensive delete link more

answered 2011-12-07 06:52:28 -0500

shaiton gravatar image

I've already got it working few times with SELinux enabled. Yes I had your issue, forgot how to resolve it. Do you have some ~/.xsession-errors which could help you?

You could also get it working with libvirt, if your hardware is supported. See the doc.

edit flag offensive delete link more

Question Tools


Asked: 2011-12-07 03:14:47 -0500

Seen: 3,310 times

Last updated: Dec 07 '11