Ask Your Question

Flapping Ethernet connection of Fedora 23

asked 2016-03-30 05:16:00 -0500

dr01 gravatar image

Since a few days I am experiencing a flapping Ethernet connection on my Fedora 23 laptop: the network connection goes down for several seconds every minute.

The problem persists in different environments (different cables and switches) and regardless of static or DHCP addressing; the connection with an USB-Eth adapter worked for one hour or so, then started behaving the same way.

The machine is up-to-date with the latest kernel (4.4.6) and packages. Booting on an older kernel (4.4.3) did not solve the problem. However, when booting on a Live CD with Fedora 21, the wired network seems to work.

Anyone has experienced this issue? Here's some troubleshooting output (concerning the eth device enp0s25):

[root@linuxbox ~]# ip address
2: enp0s25: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether ec:b1:d7:97:9d:f2 brd ff:ff:ff:ff:ff:ff
    inet brd scope global enp0s25
       valid_lft forever preferred_lft forever
    inet6 fe80::eeb1:d7ff:fe97:9df2/64 scope link 
       valid_lft forever preferred_lft forever

[root@linuxbox ~]# dmesg 
[ 1403.944457] ax88179_178a 4-5:1.0 enp0s20u5: ax88179 - Link status is: 0
[ 1409.490222] e1000e: enp0s25 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
[ 1409.490232] e1000e 0000:00:19.0 enp0s25: 10/100 speed: disabling TSO

[root@linuxbox ~]# ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=54 time=4.79 ms
64 bytes from ( icmp_seq=2 ttl=54 time=4.48 ms
64 bytes from ( icmp_seq=3 ttl=54 time=4.57 ms
64 bytes from ( icmp_seq=50 ttl=54 time=4.62 ms
64 bytes from ( icmp_seq=51 ttl=54 time=4.50 ms
64 bytes from ( icmp_seq=52 ttl=54 time=4.81 ms
64 bytes from ( icmp_seq=53 ttl=54 time=6.16 ms
--- ping statistics ---
65 packets transmitted, 11 received, 83% packet loss, time 64018ms
rtt min/avg/max/mdev = 4.486/4.803/6.164/0.469 ms

[root@linuxbox ~]# ethtool enp0s25
Settings for enp0s25:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
    Advertised pause frame use: No
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: off (auto)
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000007 (7)
                   drv probe link
    Link detected: yes

[root@linuxbox ~]# ethtool -S enp0s25
NIC statistics:
     rx_packets: 10222
     tx_packets: 1774
     rx_bytes: 1146761 ...
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-04-01 02:15:45 -0500

cialu gravatar image

Usually, a network to work properly, also with ethernet connection, need some right parameters. Especially,

IP Address



Default Route

Name Server

You can check these parameters and values:

# cat /etc/resolv.conf
# ifconfig
# route

You must check also if the DNS works properly and if not you can change with Google values:

If you use a static IP Address, try to change it with another value or try to use the DHCP addressing.

edit flag offensive delete link more



Problem solved. This was one of those nasty problems which have different causes for the same effect. In one environment someone configured his machine with the same IP address as mine. In the other environment we're not sure what caused the glitch, but we suspect a problem with the Internet connection.

dr01 gravatar imagedr01 ( 2016-04-01 02:42:15 -0500 )edit

Question Tools

1 follower


Asked: 2016-03-30 04:59:07 -0500

Seen: 250 times

Last updated: Apr 01 '16