Ask Your Question

After and entire dan, much googling, youtubing and hitting forums, I still can't get VirtualBox to work.. Can someone please tell me what the hell I'm doing wrong?

asked 2016-03-29 23:51:42 -0500

updated 2016-03-30 04:15:23 -0500

hhlp gravatar image

Hi guys, please believe me when I say, I've tried every string ove words in google to try and get a solution to my problem. I followed step by step, word for word, copy, paste, and no love was had. I tried others too, uninstalled VirtualBox, installed dmsg first, then tried again, the uninstalled and cleaned again, updated the repo, tried again, and all I ever get whenever I want to power up my virtual machine is:

Failed to open a session for the virtual machine victim.

The virtual machine 'victim' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: MachineWrap
Interface: IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}

I get this is a kernel issue, I just can't seem to get it right. I tried everything from the official method on the Oracle site to an after market dodgy work around here Please can someone tell me what I'm doing wrong? My head hurts from fighting this crap now :(

edit retag flag offensive close merge delete



Well, since it is VirtualBox, will start with the real issue, Fedora Update its kernels faster and Virtualbox so they always are behind with their kernel modules, so you must use and old Fedora kernel in order to make it work. With their method. You can also try method, but for the amount of complain here about it nor sure it works as the same happen to them. So my suggestion is give Fedora kvm manage with virt-manager or gnome-boxes a try it works with all virtualization, plus no issue with updates.

aeperezt gravatar imageaeperezt ( 2016-03-30 00:03:24 -0500 )edit

Is there a specific reason that you must use Virtualbox?

snowolfe gravatar imagesnowolfe ( 2016-04-01 18:59:21 -0500 )edit

you using secure boot?

gobigobi66 gravatar imagegobigobi66 ( 2016-04-03 20:47:54 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2016-03-30 09:29:37 -0500

florian gravatar image

If you want the hassle-free method, just use the version from Oracle's website,. Setup their repository by copying it to /etc/yum.repos.d/, install kernel-devel and dkms (!!), restart, install VirtualBox-5.0 (sudo dnf install VirtualBox-5.0). I am doing that this way since Fedora 18 and never had a single problem with VirtualBox. Yes, it's not a free GNU piece of Software like kvm/qemu implemented in Boxes but it also works just fine.

edit flag offensive delete link more

answered 2016-04-01 19:12:40 -0500

snowolfe gravatar image

As noted above - KVM/libvirt with virt-manager (or gnome-boxes for a simpler tool) will read and write to any of the standard virtual disk formats (Virtualbox, VMware, the Windows product whose name I forget, and others) that you might be trying to reuse - all you need to know prior to starting is the 'virtual' hardware the virtualised OS is expecting to find; how much RAM, how many CPUs, networks, etc.

If the virtualised OS is Linux based, then it probably won't care, however, if it is a Windows OS you might need to get the right virtual hardware devices defined before it will boot successfully. I have done this successfully on a number of occasions, usually RAM and CPUs are enough to get you running. It is possible to add VirtIO based drivers to the Windows OS as well, boosting performance of the virtualised OS.

For most users, the functionality of KVM is as good as Virtualbox, and performance should be better, particularly if the VirtIO drivers are in use.

edit flag offensive delete link more

answered 2016-04-01 19:24:25 -0500

sergiomb gravatar image

If you try VirtualBox from rpmfusion , you need configure rpmfusion repos , uninstall previous Oracle versions. I made this howto , but still incomplete , also don't have support for CentOS/RHEL 7.2/6.7/5.11 (maybe one day) .
Also you may need disable secure boot on BIOS, to work out of the box , signing VirtualBox kernel modules (still) isn't a easy task. Anyway you may detail more your problem , what Fedora version ?

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-03-29 23:51:42 -0500

Seen: 145 times

Last updated: Apr 01 '16