Ask Your Question
0

Could not update ICEauthority file after F16 install

asked 2011-11-14 06:41:17 -0500

block243 gravatar image

updated 2011-11-17 17:04:36 -0500

Hi All,

Hope you can help. I have a multi-boot laptop with Fedoras F12, F14 and now F16 all using the same /home directory on its own partition. (I've got enough space so I like to keep older versions, just in case)

When I got to the stage in the F16 install where I create a user I typed in my username and it recognised that a /home/user already existed.

All appeared well until I tried to log on when I got

Could not update ICEauthority file.

When I went back to my F14 install my user account was also messed up, but I searched and found that

[root@localhost ~]# chown john.doe -R /home/john.doe

worked and fixed the problem in F14, but it persists in F16.

I turned off SELinux with

[root@localhost ~]# setenforce permissive

and

[root@localhost ~]# restorecon -r /home

but this did not fix things.

Any suggestions appreciated.

Update:

I'm making progress but I'm still not there.

FranciscoD your suggestion did fix the permissions on .ICEauthority

chown -Rv username:groupname /home/username
chmod -v 0600 /home/username/.ICEauthority

It now looks like you said it would

[ankur@ankur ~]$ ls -lash .ICEauthority 
76K -rw-------. 1 ankur ankur 69K Nov 13 20:06 .ICEauthority

and when I try to log into my F16 install it does not mess up my F14, but I still get the same error

Could not update ICEauthority file when I log into my F16 install.

I can create new accounts in my F16, so should I just do that and copy my old account files across?

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
0

answered 2012-06-20 21:51:29 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

How I fixed this issue at the time I was/am using Fedora 17

Make sure your user matches in these three files:

vi /etc/group

vi /etc/shadow

vi /etc/gshadow

If everything matches in these directories then Double check that your permission are correct on your home folder as stated above.

chown -Rv username:groupname /home/username

chmod -v 0600 /home/username/.ICEauthority

also make sure your username matches the name of your home directory (Case sensitive)

Once these are all confirmed

cp /home/username/.ICEauthority /home/username/.ICEauthority.bak

go back to your GUI login and you should be able to get in. It took a good 30 seconds to actual boot in to the GUI and I had to reset my background but all is well afterwards.

Hope this helps someone.

Note: If this worked for you and you now have a new .ICEauthority file your safe to delete the .bak you created earlier.

rm -f /home/username/.ICEauthority.bak

Make sure to Change username with your username

edit flag offensive delete link more
0

answered 2011-11-14 11:32:33 -0500

FranciscoD_ gravatar image

I've looked around and it seems faulty permissions is the cause of this error.

This is what my .ICEauthority file's attributes are:

[ankur@ankur ~]$ ls -lash .ICEauthority 
76K -rw-------. 1 ankur ankur 69K Nov 13 20:06 .ICEauthority

I'm guessing this should be the fix:

chown -Rv username:groupname /home/username
chmod -v 0600 /home/username/.ICEauthority

Do verify that the file's attributes have been corrected.

edit flag offensive delete link more
0

answered 2011-11-21 15:42:17 -0500

jfmchivall gravatar image

I had this issue, and fixing permissions did not solve it for me. I finally noticed that there were several files with the filenames of the form .ICEauthority-XYZ in my home dir. No idea how they got there, but deleting them all solved the problem. This was far preferable to having to create a new user account and migrate everything to there!

edit flag offensive delete link more
0

answered 2011-11-17 23:14:52 -0500

FranciscoD_ gravatar image

I think I know what is causing this :P

In F16, we switched to UIDs from 1000 iirc while in F14, we began from 500. Therefore, in all probability, the UID of your user in F14 is 500 while on F16 is 1000 which is why permissions keep going hay wire.

http://fedoraproject.org/wiki/Features/1000SystemAccounts

[root@ankur ~]# egrep "ankur" /etc/passwd
ankur:x:1000:1000:Ankur Sinha:/home/ankur:/bin/bash

Do the same on your F14 and F16 installs, you will(should) see a difference.

The solution, that I can think of, is to make the UIDs match, so edit the F14 user to make the UID 1000 (or whatever the F16s is). That would probably fix it.

edit flag offensive delete link more
0

answered 2011-11-14 13:00:00 -0500

SoumyaC gravatar image

Can you try and restore the gnome session in F16 and check if its working -

# sudo yum reinstall gnome-session
edit flag offensive delete link more

Comments

ok that's good that it got solved :)

SoumyaC gravatar imageSoumyaC ( 2011-11-15 03:15:59 -0500 )edit

Question Tools

Stats

Asked: 2011-11-14 06:41:17 -0500

Seen: 5,335 times

Last updated: Jun 20 '12