Ask Your Question
1

Chrome sleep on disk while not active! &RAM and swap go crazy!

asked 2016-03-18 15:00:57 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Well I notice that strange behavior on chrome browser since i moved to Fedora from Debian based distros , everytime Im away from laptop and not active and screen locked , when i unlock it and choose the open chrome icon in my menu bar the mouse and keyboard become freezing and slow! I just managed to open kSysguard to see the ram and swap usage and i notice that chrome sleeping on disk and swap is go crazy!! like this screenshot with my mobile just managed to catch ! http://s29.postimg.org/3s5ipiv07/1233... so is there any luck to stop this strange behavior? p.s i'm using fedora 23 with mate desktop also appeared on cinnamon desktop too ...

edit retag flag offensive close merge delete

Comments

It might be that your computer is going to hibernation which does a suspend-to-disk. This results in writing all what is in memory onto disk when going to hibernation. When waking up again, it means to read everything from disk again and put it back to memory. This is a very disk intesive process and could lead to the lags you describe. Try to open the power manager settings and disable hibernation. Depending on your needs, choose suspend or "Switch off display".

thomaswood gravatar imagethomaswood ( 2016-03-20 06:12:58 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-03-21 04:49:46 -0500

genodeftest gravatar image

Your Chrome is using 2.9 of 3.7 GiB of your RAM. You probably should either close some tabs in chrome (to reduce memory footprint), install more RAM in your computer or choose a different browser with less RAM usage (e.g. Firefox). All of these tips should reduce memory being swapped out to disk.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-03-18 15:00:57 -0500

Seen: 123 times

Last updated: Mar 18 '16